1

Intro/Problem

Hi everyone,

I am in over my head here.

I have a Dell R300 server running Windows Server 2003. It went down late last night and upon trying to restart it, I got the following Errors about the PERC 5e RAID controller installed.

1) At Windows Login Screen:

Controller event log: BBU disabled, changing WB virtual disks to WT: Controller 0 (PERC 5/E Adapter)

2) On front of R300 Server:

E171F PCIE FATAL ERR B0 D4 F0

We tried re-seating the RAID controller in the same PCIE slot with no change.

We then tried switching it to the other PCIe slot and upon boot it couldn't find the controller configuration at all, so we moved it back to the original slot.

I booted into the PERC Config BIOS and see that there may be a firmware update available. RAID controller info is as follows:

Controller Info

PERC 5/E

Package 5.2.1-0066

FW Version 1.03.40-8316

BIOS Version MT28-8

Considerations

I have considered that this might be a bad RAID controller and that I may need to backup and import the config to another controller, but am open to any suggestions.

Are there any further diagnostic/troubleshooting attempts I can make to get this PERC 5/e back online, or do you think this controller is toast?

Would it be worth trying to boot to the Dell OpenManage Assistant CD and see if any additional options are available? I don't believe I have this software readily available, so I would probably need to download and burn it if that's an option.

Assuming this controller is dead, what are the steps for backing up and restoring this config on another server/controller?

Forgive my ignorance as this level of troubleshooting is not something I have a great deal of experience in.

Thanks for your time,

Aaron

3
  • 1
    Does the PERC 5 not store the config on the disks? It's been a long time since I saw a controller that didn't do that. If I were in your shoes I would call Dell and pay for a replacement controller and support to get the array back up. – Todd Wilcox Jun 15 '15 at 19:01
  • 1
    If the OS boots then the controller is most certainly not dead. – joeqwerty Jun 15 '15 at 19:09
  • Sorry, I should have been clearer on that. It boots to login screen SOMETIMES, but has been blue screening since about 2pm Central and we never get passed login. We have pulled the controller, put it in another computer, and hooked it up to the SAN. So far, so good. – Aaron Jun 15 '15 at 19:54
2

So as you said it still boots to the windows login screen I assume with the exception of the error message you posted the server is running fine?

Controller event log: BBU disabled, changing WB virtual disks to WT: Controller 0 (PERC 5/E Adapter)

Basically this error message only tells you that the battery of your RAID controller is bad/gone/not present and that your virtual disk caching mode was therefor set from write-back to write-through. The reasoning behind this is that your controllers cache is not backed by the BBU (anymore) so it's unsafe to use it for write-caching in the event of a power-loss.

In the moment the only problem which should occur is slightly degraded write performance.

Normally the PERC5 also beeps on boot and I'm pretty sure to remember they also have a special error message for battery low-power, which makes me think that in your case:

  • the connection to the BBU is somehow gone (you could try to reattach it),
  • or your battery is totally dead so it isn't even recognised by the controller anymore.

In the end nothing to worry about - pull a working BBU / controller from another server or get yourself one on ebay.

Dead BBU batteries are a really common problem with any controller (the lithium ion cells just wear off with the years) and the reasoning why most RAID controllers use flash-based cache and no BBU nowadays.


Regarding howto replace the controller (if it should be needed). The PERC5 does indeed store the volume configuration on the disks themself. When you replace the controller it will just show all drives as "foreign". Inside the RAID BIOS there is a menu "Foreign Config" which allows you to import the config from the drives. This process works pretty flawlessly IMHO.

3
  • 1
    The server DID boot this morning, but we have been getting a blue screen since about 2:00pm Central. We are now thinking it's the motherboard in the R300. We moved the controller card to another computer and hooked it back up to our storage device. It is currently seeing the drives, but is giving us "Access Denied" when we try to access the data. – Aaron Jun 15 '15 at 19:50
  • 1
    Sounds like a more complicated case. The error message regarding the BBU sounds totally unrelated to the other problems you describe. What's your storage device? Powervault MD{$x}000 series? You may need to configure your host groups/host access if you get "Access Denied" errors when accessing the volume. – s1lv3r Jun 15 '15 at 20:08
  • Thanks s1lv3r. It turned out to be a really simple permissions issue. Yes, we are using a MD series SAN. So basically the server died, not the RAID Controller. We are now building a new server and have the RAID controller setup in temporary box so we can access our mission critical data on the SAN. I greatly appreciate everyone's responses! – Aaron Jun 16 '15 at 13:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.