We are running Microsoft Exchange Server 2013. All of our internal mail is working fine and most external mail is good however, recently, we started having issues with sending & receiving to a few external domains.

At first, our users complained that it can take hours for mail to get through so, I took a look at the Exchange Queue Viewer and I noticed the following error on a about 5 different domains.

[LRT=17/06/2015 8:36:14 AM);(LED=441 4.4.1 Error encountered while communicating with primary target IP address: "Failed to connect. Winsock error code 10061, Win32 error code 10061." Attempted failover to alternate host, but that did not succeed. Either t

I have searched all over the web for a solution however, I did not find anything. Unfortunately, I am not experienced with Exchange so if I have not supplied enough information, can you point me in the right direction at least.

So far, I have tried "retrying" the stuck messages with no success and I have also tried restarting the Exchange Transport Service and this did not help.

SMTP 441 is a failed connection, see here for further reference. Winsock 10061 is Connection Refused. I would say you need to investigate layer 3 and see if you can actually connect to the correct endpoints on the outside world. You can use a site like mxtoolbox to pull up an MX record for a given domain (your intended recipient) and ensure you can name resolve and route to the address. You could also telnet to port 25 and test SMTP.

Next up, look at your Connectors in Exchange. You might have some specific connectors that connect to other internal organizations (parent company or similar), and then an external connector for 'everything else'. It is possible you have a misconfiguration there. In Exchange PowerShell, run Get-SendConnector to get some properties. That might clue you in on the issue.

up vote 0 down vote accepted

This was a ISP issue. Solved by logging a call with the ISP.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.