0

When i am trying to install odoo through yum i am getting the following error.

Finished Dependency Resolution Package: odoo-8.0_20150617-1.noarch (odoo-nightly) Requires: python(abi) = 2.7 Installed: python-2.6.6-52.el6.x86_64 (@base) python(abi) = 2.6 Available: python-2.6.6-51.el6.x86_64 (test) python(abi) = 2.6 You could try using --skip-broken to work around the problem You could try running: rpm -Va --nofiles --nodigest

Steps i followed mentioned below.

  1. installed the pstgresql 9.4.4
  2. updated the python 2.6 to 2.7
  3. Configured odoo repository
  4. tried to install odoo using yum install odoo

I have updated the python also.

python --version

Python 2.7.6

Can any one help me to solve this issue

  • you have to install python from source to separate directory, then create virtual environment and install all dependencies inside it. – ADM Jun 17 '15 at 5:55
  • Better to install CentOS 7. – Michael Hampton Jun 17 '15 at 10:59
0

correct way is to creating virtual environment.

yum -y install wget gcc zlib-devel bzip2-devel openssl-devel ncurses-devel sqlite-devel readline-devel tk-devel gdbm-devel db4-devel libffi-devel libxslt libxslt-devel libxml2 libxml2-devel openldap-devel libjpeg-turbo-devel openjpeg-devel libtiff-devel git libpng libXext libz.so.1 xorg-x11-fonts-Type1 curl cabextract

cd /usr/local/src
wget http://python.org/ftp/python/2.7.8/Python-2.7.9.tgz
tar -xzf Python-2.7.9.tgz
cd Python-2.7.9
./configure --prefix=/usr/local --enable-shared LDFLAGS="-Wl,-rpath /usr/local/lib"
make
make altinstall

wget https://bitbucket.org/pypa/setuptools/raw/bootstrap/ez_setup.py -O - | /usr/local/bin/python2.7
/usr/local/bin/easy_install-2.7 pip virtualenv

this is what you must have on centos 6.6

[root@server ~]# python --version
Python 2.6.6
[root@server ~]# yum install python
Loaded plugins: fastestmirror
Setting up Install Process
Loading mirror speeds from cached hostfile
 * base: mirror1.babylon.network
 * epel: mirror1.babylon.network
 * extras: mirror1.babylon.network
 * updates: mirror1.babylon.network
Package python-2.6.6-52.el6.x86_64 already installed and latest version
Nothing to do
[root@server ~]# cat /etc/redhat-release 
CentOS release 6.6 (Final)

this is the full guide i found: https://odootricks.wordpress.com/2014/09/30/installing-odoo-8-on-centos-6-with-virtual-python-install/

  • When i check python version i could see that 2.7 [root@server ~]# python --version Python 2.7.9 – Mobin Jun 17 '15 at 6:53
  • really? Finished Dependency Resolution Package: odoo-8.0_20150617-1.noarch (odoo-nightly) Requires: python(abi) = 2.7 Installed: python-2.6.6-52.el6.x86_64 (@base) python(abi) = 2.6 Available: python-2.6.6-51.el6.x86_64 (test) python(abi) = 2.6 You could try using --skip-broken to work around the problem You could try running: rpm -Va --nofiles --nodigestdo you understand this message??? :) – ADM Jun 17 '15 at 9:40
  • I didn't understand this message.but i have installed python 2.7. Now i am trying to install the odoo using odootricks.wordpress.com/2014/09/30/… – Mobin Jun 17 '15 at 11:43
0

I have installed odoo by using this document https://odootricks.wordpress.com/2014/09/30/installing-odoo-8-on-centos-6-with-virtual-python-install/

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.