1

My Cacti stopped graphing network data for servers that I monitor using snmp. I am able to manually query the corresponding counter using snmpget

$ snmpget -v 2c -c XXX XXX .1.3.6.1.2.1.31.1.1.1.6.4
iso.3.6.1.2.1.31.1.1.1.6.4 = Counter64: 13662736603625

However the Counter does not increase until I restart snmpd on the server.

In the syslog of the server I noticed theese lines:

Jun 17 16:25:33 ns375911 snmpd[18307]: Cannot statfs /sys/kernel/security#012: Permission denied
Jun 17 16:25:33 ns375911 snmpd[18307]: message repeated 17 times: [ Cannot statfs /sys/kernel/security#012: Permission denied]

The problem appears to affect only servers that I installed after a certain date (somewhere around may 2015)

I have Ubuntu 14.04.2 LTS.

Can anybody explain what is going on here and how can I fix it? I think the error causes snmp to abort and prevent it from updating the network interface statistics. Can I configure snmp to ignore this sys folder? Or give it permissions?

2

turned out the server was installed with a gsecurity enabled kernel andthe respective group was not enabled in grsec kernel config

i could have done that but i opted for the easy option of just installing the default server kernel via apt repositories

on ubuntu that would be apt-get install linux-image-server

dont forget to check the order of kernels in /etc/grub.d/ in my case that was cd /etc/grub.d && mv 06_OVHkernel 25_OVHkernel

now update-grub && reboot

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.