0

I am having a problem that I just can't sort out.

Windows server 2008 R2, This server has been working fine since 2013. Now all of a sudden when I am logged in remotely through RDP the RDP window will just freeze. If i try to reconnect, all I get is a black screen. If try to log in to the server while physically sitting in front of it, the log in window doesn't even come up. However the server is still running because I can copy files to its shared folders without issues when this happens. The only way I can get back into the machine is by rebooting.

Things I have tried: setting a timeout to 10 minutes on disconnected or idle RDP sessions.

Pressing ctrl + alt + end / esc when I get the black screen in RDP - doesn't work.

Disabled bitmap caching, and tried reconnecting with different resolution.

Checked for kb2830477 - not present.

I have also tried everything listed on this article, http://www.grishbi.com/2015/01/rdp-black-screen/

I am not sure what else to do. This server worked perfectly fine for years, now all of a sudden it's not working.

Any help would be greatly appreciated. Thanks.

  • Not really a fix but a work-around that might provide troubleshooting info: when connected with RDP and presented with a black screen, have you tried CTRL+ALT+END and then starting Task Manager, and then New Task, "explorer.exe"? Sometimes that starts up the shell if it's not starting on its own. If that works around it there might be a problem with userinit in the registry. – Todd Wilcox Jun 18 '15 at 17:58
  • As I stated in the question, I have tried ctrl + alt+ end. It does nothing. – Kyle Vaughan Jun 18 '15 at 18:05
  • Oh, I thought you were doing CTRL+ALT+END followed by ESC to see if it would kick explorer.exe into action, which is a thing. The "/" was open to interpretation. – Todd Wilcox Jun 18 '15 at 18:20
1

I know its been a while since anyone has posted to this question but I thought I would share my experience. Some coworkers were having a similar experience on a 2008 r2 server. When I logged in I noticed an unidentified network icon in the taskbar. It turns out that there was an IP conflict on the network and shutting down the conflicting machine seems to have fixed the problem. I'll update if the problem returns but so far, so good.

0

It sounds like your previous RDP session hasn't completely terminated, and is stuck in an in-between state. I've seen similar situations when you log-out and an application that runs on the tray refuses to close on logout, and causes the session to be hung. Try following Todd Wilcox's suggestion and press to bring up the task-manager and look for processes that are running under the user-account in question, and start killing them one by one until the session terminates completely. This can help you track down the offending application. Also think about applications that have been updated or installed since the problem started happening.

  • As I stated in the question, I have tried ctrl + alt+ end to bring up task manager, It does nothing. Also when this balck screen happens, I cant even log on while sitting in front of the server itself. Also trying to log on with different user accounts gives the same results. – Kyle Vaughan Jun 18 '15 at 18:07
  • Sounds like your server is seriously hozed. Windows <control><alt><del> (and <control><alt><end> for RDS) sequences are interpreted at the lowest level possible... if windows isn't responding to it... that means something is seriously wrong and you should seriously consider wipe/reload. It sounds like something at the kernel-level is seriously screwed up. – TheCompWiz Jun 18 '15 at 18:13
  • ctrl + alt + delete / end works fine once you are logged in, it only doesn't work when you are sitting at the black screen. – Kyle Vaughan Jun 18 '15 at 18:16
  • Have you tried logging in at the console with the same credentials? Same results? different? Control-Alt-Del sequences should ALWAYS work. There is no easy programmatic way of overriding the sequence... short of some very dirty hacks. – TheCompWiz Jun 18 '15 at 18:22
  • Honestly, this sounds more & more like the server has become compromised or corrupted. Just wipe/reload... and you'll quickly find yourself spending less time than trying to troubleshoot the problem. – TheCompWiz Jun 18 '15 at 18:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.