1

I'm trying to mount an NFS share setup on my Synology Server to my Windows Server 2012 server. Here's what I've tried:

net use Z: \[ip address][share folder] /user:xxxxx [password]'

mount -user:xxx -p:MyPassword \[ip address][share folder]\ Z:

Neither worked though. They complain about the username/password not being correct, but I know for a fact they are. I've used them to setup other shares on 2008 R2 servers.

I tried mapping a network drive by right clicking 'Network' in 'Windows Explorer' but that didn't work either. It gives me the message 'the specified server cannot perform the requested operation.'

Any suggestions of ideas of what I'm doing wrong?

1

The command "net use"... is for mounting Windows shares (SMB/CIFS).

The command "mount"... might be usable to mount NFS disks, but that command does not take any user or password options.

When you mount a Windows share you provide a user with password and that user will be responsible for all accesses on the server. When you mount an NFS disk all users on your client will be able to access files on that disk and different users might have different privileges on that disk.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.