I have a NetBackup 6.0MP7 installation running on Windows Server 2003. It functions as the only Master Server and Media Server. I swap a full set of tapes in and out every week, but leave a set of tapes with their Volume Pool set to "Scratch" in all the time. The weekly tape sets then get rotated back in after a period of time. Largely, this works fine. I seldom actually need the scratch tapes, but every once in a while, a backup will run over what I have dedicated to the task.

However, one week's set of tapes consistently gets declined in favor of the scratch pool. The backup policies are the same for every week, they all have "Policy Volume Pool" set to "NetBackup", and all of the tapes for every week (beside the scratch tapes) have had their pools assigned as "NetBackup", definitely including the week that always gets ignored.

That said, it doesn't ignore all of the NetBackup pool tapes for that week. It does usually write to two or three of them, but it writes to like 20 of the scratch tapes. (I haven't thought to look to see if it's always the same two or three tapes.) And this problem never seems to occur for any other week.

It doesn't load the tapes and then reject them; it never seems to try to use them at all. They are not flagged as frozen. They are all active and unassigned when I swap them in.

The tapes are in a Quantum PX510 tape library. The NetBackup server is attached to the library/robot via fibrechannel going through an HP-branded Brocade switch.

I'm not an expert on NetBackup at all. I don't really even know where to look. Any advice on logs to look at or logging to enable or really anything at all would be appreciated. I'll keep an eye on the question and update it if anyone needs any more info to help.


It sounds like they're in the proper media pool, have you checked the Overwrite Protect and Append settings for those tapes? Perhaps they're set to not allow Overwrite or Append operations during the time and date period that the backups are running.

  • Well, any data on the tapes has expired by the point they should be being written to, but I'll check into it. I'm not seeing those settings, though. Where do I configure them? – wfaulk Sep 30 '09 at 22:53
  • I use BackupExec not NetBackup but I've got to assume that there are settings to set the Overwrite Protection and Append level for your media. Look in the media vault, pool, set, or library (whatever it's called in NetBackup. – joeqwerty Sep 30 '09 at 23:21

I am assuming you have a barcode reader in that library...
Have you checked to see if the Logical Media labels match the physical labels on the tapes? You can check this through the Netbackup Admin Console -> Media -> Volume Pools -> NetBackup and examine the MediaID vs. the Barcode.
If they are different, then that's your problem. I would try relabeling the media in your NetBackup pool that it refuses to write to. Relabeling can be destructive, but if the tapes aren't being used, then I am guessing it's not much of an issue...

EDIT: To clarify, I meant to logically relabel them to match the barcode, not physically.

  • Good idea. I don't think that's it, because I don't think it ever even tried to mount those tapes, but I could be wrong. Regardless, there's no harm in me relabeling the tapes. I'll give it a shot when they come back in from offsite. – wfaulk Sep 30 '09 at 22:54

In the NetBackup nomenclature, medium switches from "full" to "unassigned" when each and every backup gets beyond the policy retention period. The retention period is counted from the time the backup have successfully completed (not started!). The retention period 1 month does not mean 4 weeks (etc).

I think you might be a little to "tight" with your retention period and it overlaps slightly on this one week. To verify this little hypothesis: just before the backup, check that the inserted media are in the unassigned state (in the media manager they have empty "Assigned" column). Do not check it AFTER the backup, because they can as well expire in the meantime.

By the way, the medium becomes "active" if it is "assigned" and any backup is written to it. So medium cannot be "active" and "unassigned" at the same time (regarding "They are all active and unassigned when I swap them in.")


Turns out that I had accidentally set some tapes to expire (not the backups on them, the tapes themselves). This is the "expiration date" as listed in the output of vmquery -m <tapeid> or "Volume Expiration" in the GUI's "Change Volumes" dialog.

I cleared this expiration and that solved the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.