10

I would like to share this mistake as i have waste for one day on this. So I think i might be useful for other

There is a puppet server setup by my colleague in infrastructure team. They provide me another window 2008 r2 to install puppet agent on my own.

I try to run puppet agent and it always show message

Error 400 on SERVER: The environment must be purely alphanumeric, not 'puppet-ca'

3
  • I want a feedback that why this question have been dowvoted so that i would consider improving the question. Commented Jun 21, 2015 at 4:23
  • 1
    Try running as sudo. I faced this error when trying to apply settings using --environment. Using sudo resolved the error. I know that's weird.
    – Vikas
    Commented Aug 8, 2017 at 17:47
  • I'll second the comment about sudo. I ran the agent as non-root and got the same error. Commented Jun 15, 2018 at 21:04

2 Answers 2

17

The root cause is that the puppet version on puppet master server is 3.8.1 However i install puppet 4.1.0 on puppet agent.

Puppet master version must be greater than or equal puppet agent version. The solution is that i uninstall puppet on puppet agent and reinstall puppet version 3.8.1 instead.

You may find previous release downloads at the following link: https://puppet.com/misc/pe-files/previous-releases

0

In my case this problem was caused by missing environment variable in puppet.conf. After running with --environment production all works as expected.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .