0

I'm in a process of upgrading our servers with more RAM, storage and H700 RAID controllers. The message on boot shows instead of the F10 option, and it reads 'System Services Update Required'.

I've already downloaded Dell Repository Manager and created an ISO with updates for our server. It was running the update and iDRAC was being upgraded from 1.06 to 1.98 version. I left the server running and when I returned it was asking to reboot. Upon reboot, same message appears, and iDRAC is still 1.06.

I have gone to configure it for remote access (CTRL+E) and set static IP. I am unable to browse and ping does not get any response on that IP. I've tried while in the config menu, as well as when the server is booted into ESXi (using different static IP).

My question is, should I even bother with iDRAC updates? If so, is there any other method of updating it?

I've looked and looked, found some posts, blogs, here and there, but can't get it to update at the moment. I'd rather have a 100% functioning server before moving back VMs onto it.

Any help would be appreciated. If all fails we may need to renew support for these servers with Dell.

Update 1: After trying to run the updates again, iDRAC is still on old version. It will pop up a message about Fan 4 that may use different speed. It will start booting normally with Temp displayed. When it gets to starting iDRAC, the fans go crazy and temp shows 25 Celcius. Shortly followed by 'Temp unavailable'. Then I will see temperature again, it will boot to ESXi, and when it's finished loading, fans go up to about half the speed with 'Temp Unavailable' still on the display. vSphere Client can't report on hardware because: Hardware monitoring service on this host is not responding or not available. I fear without this Veeam One will not be able to report on the status of the server.

Update 2: Tried everything suggested and contacted Dell Support. They have suggested few of the things I've tried, as well as reinstalling the old RAID card, restoring iDRAC settings to default, but nothing has worked. They suggested a motherboard replacement will be required to fix this. Not sure what's caused the iDRAC and LCC to fail ...

  • AFAIK you can update from windows or linux, check the download section for your server on dell site. If the current version is new enough, you can update via internet from system services. I did not have to mess with repository manager. – Dan Jun 19 '15 at 11:40
  • We're running ESXi on this server so can't run Windows or Linux directly on it. System Services are unavaliable. It says 'Require Update' and unavailable if I use F12 to go to Boot selection screen. – Robert Kołodziej Jun 19 '15 at 12:28
  • Boot a linux live stick or cd, do the update. One catch, dell linux firmware update utility requires bash to be default shell, not dash – Dan Jun 19 '15 at 13:01
  • The ESXi has only been installed so theoretically I can install Windows on there and run the update from there. I've looked on Dell's website but can't find the iDRAC driver ver 1.98 – Robert Kołodziej Jun 19 '15 at 13:11
  • I think I found it: iDRAC6 Monolithic Release 1.98 – Robert Kołodziej Jun 19 '15 at 13:19
0

Are you able to SSH into the iDRAC's static ip? If you can SSH into it, restarting it sometimes helps to get the webinterface back up: racadm racreset

Having an updated iDRAC might be necessary for it to be able to read out the new raid controller and actually find your disks, in case you ever need to do some remote management or something breaks.

  • For management we will most likely be using Veeam One. The update somehow broke things as I am now getting the Lifecycle driver version as 0, the fans go mental and there's no temp display on the LCD. I'm running the driver update ISO again, and just saw a brief message when it starts the iDRAC update, not to turn off the server or install anything else for 30 minutes. But then it just moves on onto the next update. I'll let that complete and then test SSH. To test it, do I need to be in the actual iDRAC Remote Config tool or booted into ESXi? – Robert Kołodziej Jun 19 '15 at 10:20
  • The iDRAC needs to be fully booted, it doesn't matter what the server itself is doing. – Exsisto Jun 19 '15 at 10:49
  • Can't get into iDRAC via SSH. Both server and the Windows machine with Putty are on the same network. Both ethernet points in the server go to our switch. Can SSH to ESXi though. – Robert Kołodziej Jun 19 '15 at 12:27
0

After a lot of going back and forth with Dell, pulling out the iDRAC Enterprise, the problem was isolated to a faulty iDRAC Exress card. Found a replacement for £30 and once replaced, everything is running as it should.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.