1

I have a WDS server configured on Windows Server 2012 R2 running as a Hyper-V guest OS ontop of a Windows Server 2012 R2 physical server. I've installed and configured WDS and Microsoft Deployment Toolkit / Workbench 2013.

I have captured a Windows 7 64-bit reference image and assigned it to several task sequences. Each task sequence deploys correctly with the exception that the machine will not successfully join the domain.

First I tried to delegate permissions and verify that the account could join another PC to the domain. I was able to join a non-WDS machine to the domain just fine. These are the same credentials provided through the customsettings.ini and dialogs that are presented during LiteTouch deployment.

However, when the deployment attempts to join the domain automatically as part of the task sequence, it fails, 4 times, and then continues on through the rest of the steps without a problem.

Once the deployment is successful I can manually join the PC to the domain using the exact same credentials.

I tried elevating the account to a domain administrator but the same issue remains.

Any ideas / pointers are greatly appreciated.

  • Is it possible the network drivers aren't installed until after the step to join to the domain? – Drifter104 Jun 19 '15 at 23:37
1

I found the issue. In reviewing the log file I found that the error was 0x89a. Some googling led to this TechNet Article which solved the problem. I was specifying the DomainAdmin as DOMAIN\User and the DomainAdminDomain as FQDN so it was trying to parse the two as FQDN\DOMAIN\User.

I modified the rules to use DomainAdmin=User and DomainAdminDomain=Domain

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.