-3

I have configured the nagios master server and nagios client servers, still after lot of debugging i couldn't achieve the communication btwn these two :( i am getting this generic error CHECK_NRPE: Error - Could not complete SSL handshake.

So i have a doubt on this check_nrpe plugin is it using the ssh in its back end to communicate?? or if this is not then does it use port 443 which of SSL to communicate. Someone please help me to understand this :)

closed as off-topic by Andrew Schulman, kasperd, Ward, mdpc, MadHatter Jul 7 '15 at 9:54

This question appears to be off-topic. The users who voted to close gave this specific reason:

If this question can be reworded to fit the rules in the help center, please edit the question.

0

By default, the NRPE daemon listens on TCP port 5666, whether it's configured to do SSL or not.

The usual causes of the error message you're getting are a firewall blocking TCP/5666, the NAGIOS server not being listed in the NRPE daemon's allowed_hosts, or a mismatch between the SSL expectations of the two ends of the connection.

  • thank you :) so when i do a telnet on 5666 it is connecting, the allowed host entry on nagios client server is perfect. any other common issues are there for this error? – Nishanth Jun 22 '15 at 10:14
  • The SSL expectation mismatch; check that the -n flag is being used by both nrpe and check_nrpe, or by neither; if only one is using it, that won't work. – MadHatter Jun 22 '15 at 10:15
  • sorry i am not sure how to check this can you please guide me out? – Nishanth Jun 22 '15 at 10:18
  • You can use ps to find out what flags a process is running with. The check_nrpe config will be in the NAGIOS config files. – MadHatter Jun 22 '15 at 10:19
  • yes thanks for your suggestion using ps command, i could able to confirm both nrpe and check_nrpe doesn't use -n flag. – Nishanth Jun 22 '15 at 10:26

Not the answer you're looking for? Browse other questions tagged or ask your own question.