0

I've created a virtual machine using virt-install with graphics --none. I want to enable vnc. I've tried

virsh -c qemu:///system qemu-monitor-command vm171-SC-1 --hmp change vnc :3

but it doesn't work

virsh -c qemu:///system qemu-monitor-command vm171-SC-1 --hmp info vnc Server: disabled

How can I enable vnc after running virt-install? I don't want to install with vnc enabled (i.e --graphics vnc,listen=0.0.0.0,port=) is not an option because I want it to send its output to the same termnial that I am in.

0

You could use virsh to edit the domain xml and append the graphics element: virsh edit <domain>

Here's the xml snippet for vnc support

<graphics type='vnc' port='5901' autoport='yes' listen='0.0.0.0'>
  <listen type='address' address='0.0.0.0'/>
</graphics>

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.