0

I am connecting to a server at another location, I cannot access network shares by hostname (\server\share). I decided to ping the server to see if I could reach it, no luck. Pinged by IP and got a response, same with fully qualified domain name. I can access by hostname if I add the server to my hosts file.

The server I am connecting to is my DNS server, I am connecting over a Sophos Astaro SSL VPN. The VPN connects fine, ipconfig /all shows the correct DNS settings.

I can also ping by hostname locally which leads me to think that the issues lies in the Astaro device.

I need to be able to access these shares by hostname, all of my users are configured to use hostname.

I feel like this is a simple issue, I have just been banging my head against the desk, I think I am burnt out.

Does anyone have any information that might point me in the right direction?

Thanks.

1
  • Can you just clarify this line "Pinged by IP and got a response, same with fully qualified domain name. I can access by hostname if I add the server" So you got a response to pinging by ip and by fqdn? What did you add the server to? – Drifter104 Jun 24 '15 at 21:31
1

It sounds like your client is configured to use a different DNS search suffix. Check your DNS configuration when you are connected to the VPN and see what the DNS search suffix is (I realise you say you checked the DNS settings, but I don't know to what detail you checked them. Did you just check that the right DNS server was being queried, or did you check in more detail than that?)

I'd post more detailed information but right now I'm on a Mac with no access to a Windows PC, but I'm pretty sure you can see your search suffix in an ipconfig /all under the "Primary DNS Suffix" under the global IP settings at the top of the ipconfig output.

2
  • And take a look at the connection specific DNS suffix for the VPN connection as well as running nslookup in debug mode when querying the single-label name of the server to see what query is actually being sent. – joeqwerty Jun 24 '15 at 22:29
  • This was the case, DNS suffix was not configured on the Astaro device. Thank you. – rtyner Jun 25 '15 at 19:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.