0

I'm trying to make network bridging to work on a Ubuntu 15.04 (I'm experimenting in order to make a QEMU/KVM virtual machine that will be visible to the outside network as if it were a distinct machine). The problem is that when I type brctl addif br0 eth0 then I lose connectivity to the network.

2
  • Define the bridge interface with eth0 as port
  • Set the IP address on the bridge interface

You will need the bridge-utils package installed (most likely is already there). Here's how you would configure this in /etc/network/interfaces. Restart the network service (or reboot the machine)

auto lo
iface lo inet loopback

auto  eth0
iface eth0 inet manual

auto bridge0
iface bridge0 inet static
  address   <your public ip>
  netmask   <netmask value>
  gateway   <your gateway>
  bridge_ports eth0
  bridge_stp off       # disable Spanning Tree Protocol
  bridge_waitport 0    # no delay unless port available
  bridge_fd 0          # no forwarding delay
| improve this answer | |
1

You need to remove IP address configuration from eth0, add eth0 to the bridge and then configure IP address on the br0 interface.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.