0

I installed Zabbix v.2.4 from sources in Debian Jessie. I followed (step by step) this guide: https://www.zabbix.com/documentation/2.4/manual/installation/install In the setup, when I have to configure the DB, I get this error:

The frontend does not match Zabbix database. Current database version (mandatory/optional): 2020000/2020001. Required mandatory version: 2040000. Contact your system administrator.

If I install from repos, the same happens. How can I fix this problem?
Thanks in advance.

1

Looks like you might have forgotten to initialise zabbix database.

Besides it is a mistake not to use official Debian packages from native repository. Zabbix-2.4 is available from "unstable". If you don't want to mix suites then it would be easier to re-build Zabbix packages rather than install from source. Package "zabbix-server-mysql" contains file /usr/share/doc/zabbix-server-mysql/README.Debian with instructions how to initialise database on first install...
Just remember avoid packages provided by Zabbix -- they are much worse than official Debian Zabbix packages from Debian repositories.

  • Thanks for your answer. I posted the solution in spanish, explaining the same. In addition, the zabbix-server-mysql need some dependences that cannot be solved in Debian Jessie, specifically with the libsnmp15, that is available only for the old stable releases. It is the main reason for using the source packages. – verovan Jul 5 '15 at 14:39
  • @verovan, you misunderstood my answer. Only incompetent .DEBs provided by Zabbix still depend on "libsnmp15". Official Zabbix packages from Debian do not have this problem. Never use packages from vendor if packages already available from Debian. See ZBX-7996 – Onlyjob Jul 6 '15 at 4:09
1

In case you have been using Ubuntu 14.04 and trying to do a new install of Zabbix 3.0 then you should first populate the database with the sql file provided in /usr/share/doc/zabbix-server-mysql/create.sql. After that it should work.

  • Please, read carefully the question: I was using Debian 8. And thanks for the answer, but this question has more than one year and the first answer is the right one. – verovan Sep 11 '16 at 5:05
  • @verovan. Yes I saw that but I just answered this question with the findings from my side because I was frustrated with the searches I did and nothing was working. So I thought of adding this answer too so that in future it might help someone. – Nitin Srivastava Sep 12 '16 at 1:05
0

This error means that the database schema corresponds to Zabbix 2.2. Therefore, Zabbix 2.4 frontend says that existing database schema does not match the expected one. If you are upgrading from 2.2 to 2.4, then you can simply start the server and it will upgrade the database automatically. After that, you will be able to use the frontend. See Zabbix documentation on the general upgrade steps and a blog post specifically on automatic database upgrade.

  • I am not upgrading. I installed from sources the 2.4 version. – verovan Jun 26 '15 at 13:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.