2

we did an in-place upgrade of a windows 2003 server to windows 2008 server. After the upgrade, couple of windows services stopped working. The error i am getting in the event viewer looks like this:

Faulting application someservice.exe, version 0.0.0.0, time stamp 0x38f21f27, faulting module ntdll.dll, version 6.0.6002.19346, time stamp 0x55024174, exception code 0xc0000005, fault offset 0x00066439, process id 0x10e8, application start time 0x01d0afd9a7dee788.

What this application does is, it reads a text file and parses the output.

In the application log, i can see it got to the file but before it can read, it crashed. I do not have source code for this application. May be it fails to open the file.

This application works fine on Windows 2003 Server.

I tried to create dump files but it did not generate any.

When i run "cmd" from Run menu and try to run chkdsk or scandisk, it throws me an error saying these commands requires DOS 6.0 or higher. But when i open Command.com from C:\Windows\System32 folder and run these commands, they work just fine.

I ran chkdsk, scandisk, sfc but none of this options have helped me fix the issue.

I am running this on Windows Server 2008 SP2 with all the Windows Updates installed.

Any help/pointers will be highly appreciated.

More details:

When i run "cmd" from the Run prompt, it shows C:\Users\User0000004. For 2003 servers, it used to show C:\Users\<myloginusername>. When i checked c:\users folder, all the folders that should have previously logged in user names were renamed to User000001, User0000002, User0000003 etc.

1

Dumb Question #1: Have you turned off UAC?

More often than not this causes issues with applications that "Worked fine in 2003".

Dumb Question #2: Have you tried ProcMon to figure out why it's crashing?

"May be it fails to open the file.": I think you nailed it here (either file or port related would be my guess), procmon will help you verify the issue. Setup the filter by process name, then look for ACCESS_DENIED or other similar errors while trying to execute the application.

Download procmon (it's free, and supported by Microsoft)

  • Yes. UAC is disabled. I used ProcMon but no access denied error. I used ProcessExplorer and paused it when the service appeared but no file handle open. i used Debug Diagnostics Tool to generate the dump but it did not generate any. It generated a trace file and had no errors in it. – Asdfg Jul 3 '15 at 15:20
  • "no file handle open" ... I assume you are expecting one then? This is a bit of a hard question to answer because the service code you are asking about was written only for you. I wonder if system libraries from 2003 were compiled in directly ... anyway, I don't think anyone will really be able to help apart from the person that wrote the code. Try expanding the procmon filter to include the ntdll.dll errors as well. – Joseph Kern Jul 4 '15 at 4:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.