1

I have 3 servers :
Server1 : Stores my data. Had a exported folder. Debian 7 - Linux 3.2.0-4-amd64 on x86_64
Server2 : "Client" where is the Server1 exported folder is mounted. Debian 7 - Linux 3.2.0-4-amd64 on x86_64
Server3 : Another "Client" on wich I'd like to mount the same Server1 exported folder. Debian 8 - Linux 3.16.0-4-amd64 on x86_64.

I'm unable to mount the NFS share on Server3 using this command :

mount -t nfs Server1:/home/exported_folder /home/folder -v  

Here's the command result :

mount.nfs: timeout set for Thu Jun 25 11:18:57 2015  
mount.nfs: trying text-based  options 'vers=4,addr=192.168.xxx.xxx,clientaddr=192.168.xxx.xxx'  
mount.nfs: mount(2): Permission denied  
mount.nfs: access denied by server while mounting Server1:/home/folder  

I used this command to mount the folder on Server2 and my Server2 fstab looks like this :

Server1:/home/folder   /home/folder nfs     nfsvers=3,rw    0       0

Server1 exports looks like this :

/home/folder (no_root_squash,rw)

What missed I ? Thanks

1

Server2 is successfully accessing the share using NFSv3. Server3 is failing to access the share using NFSv4.

Why don't you try using the same nfs options on server3 (nfsvers=3,rw) and see if anything changes?

  • I still use NFSv3, never NFSv4 :/ – nicolasfo Jul 1 '15 at 10:45
  • What i meant to say, was that your mount command on Server3 is not using nfsv3. The second line of your output says as much. Try forcing it with "-o vers=3" in your command. – Andy Jul 1 '15 at 11:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.