0

Here is my environment:

  • My email server is hosted externally (not on Lotus Domino) - let's call it domain.com
  • I have an existing Lotus Domino Application Server (9.01) [ServerA]
  • A new Domino Application Server (9.01) [ServerB]

Configuration:

  • Any emails generated by the application are sent to an ISP (authenticated) using the 'Relay host for messages leaving the local internet domain' setting on the configuration document (with authentication). This is only configured for the administration server.
  • I have some group mailboxes that receive Domain.com email via Andy Brunner's excellent POP3Collect solution. This downloads the emails from the external host to the Lotus Domino server and routes them to the group mailboxes. In order to achieve this, it modifies the email so that it goes to a fictitious domain called InternalDomain.com. I then have mailin databases configured with email addresses (@internaldomain.com).
  • In order to configure the Domino Server to send emails, it does not know that the server is on domain.com (because if it did then it would try to route emails to the Domino server). I had to create a Global Domain Document for InternalDomain.com. All emails to domain.com then get routed to the ISP for delivery.

My issue:

  • This has all worked perfectly well. Then I added another server. Both Domino servers are on the same notes named network. I assumed that Domino would know that in order to route emails it would send them to the server configured to send mail to the ISP. This is not the case. Email is dying on the new server, and is not going to the admin server for delivery.
  • I would like to continue to route all mail from the one server. I have thought about using a SMTP connection document, however my ISP requires me to authenticate in order to send mail, so I see the only option as having the configuration document setting for the ISP details.
  • How can I get the new server to send all emails to the admin server for delivery?

Additional info re configuration document:

  • I had the setting 'SMTP allowed within the local internet domain' in the configuration document set to 'Disabled' as I believe that would mean it will force the routing to be done via Notes Routing, not SMTP. If I change it to 'All messages' then this has no impact on the mail not becoming dead.
  • The 'Servers within the local Notes domain are reachable via SMTP over TCPIP' setting is set to 'Only if in same NNN' - again no difference if it is different.
  • If I change 'SMTP used when sending messages outside of the local internet domain' to Enabled then the server tries to route the emails directly from there. Not routing them through [ServerA] as required.
  • The mail continues to die, and I get the message 'No route found to domain gmail.com. Check Server, Connection and Domain documents in Domino Directory.

If there is an alternative way I can route the mail to the external SMTP host (using a username and password) then I am open to that.

I am sure something dead basic os being overlooked and may have been set historically that may be preventing this.

0

This sounds like there is a connection document missing, which explains that Server 02 should route emails to server 01. Did you have any connection documents in place? If not please create a connection document to route the emails to your master SMTP Server.

This one might help (however do not fully know your environment):

Connection Type: SMTP
Source Server: Your outgoing Domino Server [ServerA]
Source Domain / connect via: direct connection
destionation server: anyhost
Destination domain: Internet
Replication Task: disabled
Routing task: SMTP mail routing
route at once if: 1 message pending
Scheduled connection: enabled
connect at times: 00:00 - 23:59 each day
Repeat interval of: 60 minutes 
Days of week:   Sun, Mon, Tue, Wed, Thu, Fri, Sat
  • I thought that connection documents were irrelevant if on the same notes names network, and that mail would route. In saying that, I did create a connection document anyhow and it does not do anything. Mail still dies on the new server saying it could not find a router to whateverDomain.com. – SydxPages Jun 28 '15 at 11:51
  • Indeed, a connection document should be irrelevant for internal email - but that would mean email sent to Notes names e.g., user/org without any @ sign in the address, or user/org@NotesDomainName. If there is an @sign and what follows does not match the Notes domain name, then the named network doesn't come into play. TIn this context, domain is not an SMTP/DNS domain. The Notes domain is the set of servers that share a replica names.nsf. All the servers should have the Notes domain name listed in their Server document, and all users should have it listed in their Person documents. – rhsatrhs Jun 29 '15 at 23:02
  • That hardly depends on your environment. Currently it seamed that the system isn´t able to find the needed SMTP Server. So if the internal routing is working please check if your outgoing server has a server connection document mentioned above. @rhsatrhs ist for outgoing emails, not internal ones as far as I understood the problem here. – BastianW Jun 30 '15 at 18:35
  • @BastianW - yes, you are right. My issue is getting the mail out of my domain. I will get an outage to test this later today. I assumed that a standard SMTP connection would ignore the SMTP authentication details on the configuration document. I have created a document as suggested however still not routing. Error message is 'No route found to domain anydomain.com from server SERVER B. Check Server, Connection and Domain documents in the Domino Directory.' Server B can connect to Server A and is doing so for replication. – SydxPages Jul 1 '15 at 10:42
  • Give the system some time to replicate the changes (and make sure the names.nsf is the same on both server). Depending on the config you have this might need a router reload (would prefer to reboot the domino server). Additional you could try a "Route *" on the console. It might also helpful to get a output from "Tell Router show". You might also try to route emails by hand as explained here until the issue is solved. – BastianW Jul 2 '15 at 11:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.