4

I recently lost a hard drive RAID 5 array controller which caused total loss of the array. I am able to restore using our Shadow Protect backup. After the restore, when I start Windows 2003 server, I receive the following stop message:

STOP: c0000218 {Registry File Failure} The registry cannot load the hive (file): \SystemRoot\System32\Config\SOFTWARE or its log or alternate. It is corrupt, absent, or not writeable.

Any ideas on how to fix this issue?

2

Looks like the SOFTWARE Registry hive got corrupted; this is quite a bad scenario, usually requiring a restore from backup, an O.S. repair from the installation media or, as a last resort, a full reinstallation.

You can try starting the Windows Recovery Console from the O.S. media and then running a disk check (CHKDSK); maybe it's just a file system corruption issue.

You can find some other tips here: http://support.microsoft.com/kb/822705.

1

Can you load the SOFTWARE registry hive using a live CD? This will at least you know where to start looking.

0

Probably a disk error or controller driver issue.

  • how would you fix the driver issue with out being able to get into windows ? – JJ01 Oct 1 '09 at 22:22
  • Did you need to install dirvers for this controller when you installed Windows, at that point in the install when you press F6 to add SCSI drivers? Or did you boot a manufacturer's CD to install, like HP SmartStart? – nray Oct 10 '09 at 3:58
  • That system was restored with all the same drivers as the original server. – JJ01 Oct 10 '09 at 22:00
0

If System Restore has been running you should be able to get a copy of the registry as detailed at KB307545. It is for XP, but should still be applicable.

  • -1, System Restore exists only in Windows XP, not Windows Server 2003. – Massimo Oct 10 '09 at 16:58
  • I ask that you revoke your downrate, it does exist in Server 2003. windowsreference.com/windows-server-2003/… – Xorlev Oct 10 '09 at 17:03
  • 1
    Xorlev System restore in Windows 2003 Server is not a supported solution. It involves installing unsupported windows XP operating system files into Server 2003. This is not supported or recommend by Microsoft. – JJ01 Oct 10 '09 at 22:00
0

First, did you restore to identical hardware? If not, did you use the Hardware Independant Restore feature of ShadowProtect?

  • Different hardware and yes we did use the HIR restore option. – JJ01 Oct 16 '09 at 5:22
  • When you did the HIR, you picked the new storage driver for the OS? I've done this a ton of times, and a few of them I have mistakenly chosen the wrong one. But since i had the image, there was the liberty to keep trying with it. – DanBig Oct 16 '09 at 23:35
0

In our case the software registry file had a CRC error, leaving the Windows 2003 server in an endless boot loop with error number c0000218. I tried the repair file system (chkdsk) from Windows recovery console. No improvement.

I found http://xphelpandsupport.mvps.org/how_do_i_repair_a_stop.htm which has an awful lot of steps.

I tried this less complex solution.

  • Use the screw driver to remove the Samsung Evo 840 mSATA boot drive from the chassis. Plug that mSATA in an mSATA to USB converter. Fire up Windows XP in a VM. Plug the USB drive. The USB drive mounts without a hitch.
  • Then create c:\backup\corrupt-registry\ folder.
  • Copy all these 5 files {system, software, sam, security, default} from c:\windows\system32\config\ to the backup folder. (this is when the OS informs me about the CRC error: 1 file could not be copied)
  • Delete the 5 files from c:\windows\system32\config\
  • Copy the 5 files from c:\windows\repair\ to c:\windows\system32\config\
  • Safely remove the USB drive
  • Plug the mSATA back into the chassis
  • Power up the computer

Boot registry issue c0000218 is now fixed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.