0

I can't find the driver for PERC H730P Mini for Solaris 10. The installation in a Dell PowerEdge R730xd fails with "no disks found".

Isn't this controller supported? Where can I get a compatible driver?

Thanks!

3
  • Have you checked the Dell support site for drivers? – joeqwerty Jul 1 '15 at 18:15
  • Yes, I only found some Windows drivers – Pavel Jul 1 '15 at 19:36
  • That probably means there isn't a driver for that OS then. – joeqwerty Jul 1 '15 at 20:38
1

The Solaris on Dell PowerEdge servers wiki lists all of the hardware platforms that Dell supports Solaris 10 with. Note that there is nothing newer that 11th-gen hardware listed, nor any support for Solaris 11 (seems that no validation testing has been done by Solaris for a while now). Your R730xd is a 13th generation system, so you won't find this driver officially provided by Dell.

However, with some quick web searching, you can find that the PERC H730p uses the LSI 3108 ROC... and so does the LSI MegaRAID 9361-8i card. The LSI Support Site shows plenty of drivers for the card, including one for Solaris 10 & 11.

7
  • Thanks! So I tried and loaded this driver during the installation, I also made sure it's loaded using modinfo | grep sas (showing mr_sas), but neither Solaris 10 nor 11 seem to list the disks in cfgadm -al or format -e. Do I have to do more? – Pavel Jul 2 '15 at 18:18
  • So modinfo shows that the kernel module / driver is there... But I'm not certain whether that means the driver is actually in use - maybe that only shows that it's installed? Perhaps check the output of scanpci -v to verify that the H730p is actually recognized? Also, have you actually configured any virtual disks from the BIOS of the card? (I'm not aware of a "pass-through" mode for this card for a JBOD mode) – JimNim Jul 8 '15 at 4:22
  • Yeah, scapci identifies the controller. I tried both controller modes - HBA and RAID, and in Ubuntu I can see the disks and mount 'em. In Solaris, however, I only see disks when I export them as RAID0 virtual disks, which I'd like to avoid. How can I check and/or enforce the mr_sas driver to be in use? – Pavel Jul 16 '15 at 18:01
  • It seems like HBA mode would be fully supported by LSI since it's mentioned in Fix/Enhancement "SCGCQ00550384" in the release notes of the Solaris 10/11 driver. Perhaps you'd need to flash the LSI (non-Dell) firmware onto the card to allow this to work as expected? – JimNim Jul 16 '15 at 18:12
  • I don't seem to be able to load the LSI firmware over the iDrac interface of my Dell server. – Pavel Jul 16 '15 at 18:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.