-1

I'm trying to make a Windows Server 2012 r2 test box automatically update and reboot in the same way 2008 servers do. I cannot use the 'Always automatically restart at the scheduled time' GPO (detailed here ) at the present time, so instead I want to manually add the relevant registry key. All the online information I can find (e.g.) suggest the following key is required:

Subkey: HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU
Value: AlwaysAutoRebootAtScheduledTime
Type: REG_DWORD
Value data: 0 (default value) or 1 (force a restart)

The problem I have is that even after adding this key it still does not force an immediate restart, instead a timer of 1 day is started.

  • Did you set Configure Automatic Updates to 4? – Michael Hampton Jul 2 '15 at 18:43
  • Thanks for the suggestion, it's important to check - the AU settings are pretty standard, option 4, install every day (for testing) at 16:00, with client side targeting and the wsus server location also set. I've tried setting the no auto-restart policy to disabled, I've also set AlwaysAutoRebootAtScheduledTimeMinutes to 15 with another key. To double check, I've added the AlwaysAutoReboot registry keys using GPP but also manually with regedit (after making sure the previous keys were removed). It will likely turn out to be something like this though... – Tom Jul 3 '15 at 7:58
0

I have been back through all the settings on a recreated base image. I set the policy keys using the local group policy editor, and this time the reboot behaviour is working as expected. The AlwaysAutoRebootAtScheduledTime key is identical in the registry to the earlier entry from GPP, so I believe that either there was a conflicting group policy (I removed a few old ones) or I made an error in one of the entries. Therefore, while the specific suggestion made in Michael's answer was not the cause, the general point is as valid as ever:

Always check, double check and then triple check the settings you have entered!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.