2

I'm trying to install windows server 2012 R2 on a VM using virt-manager on centos 7. During the install it will not allow me to select the DVD drive (greyed out).

I tried the following command:

mount -r -t iso9660 /dev/sr0 /mnt/DVD/

The DVD mounted without error but there is only one file:

readme.txt

This disc contains a "UDF" file system and requires an operating system that supports the ISO-13346 "UDF" file system specification.

So I tried the following command: mount -r -t iso13346 /dev/sr0 /mnt/DVD/

got this error: mount: unknown filesystem type 'iso13346'

Could it be that the DVD drive I'm using is too old? It was manufactured in 2003...

4

Don't specify a filesystem type; mount will figure it out (correctly).

And if you're trying to install Windows in a virtual machine, you do not need to (and should not) mount the image at all. Simply provide the path to the ISO when setting up the VM in virt-manager.

Virt-manager install media selection page

| improve this answer | |
  • That worked, however if I only have the DVD and no .iso do I have to make an iso file from the DVD? – prodigerati Jul 2 '15 at 16:48
  • No, you just point virt-manager at the DVD drive. – Michael Hampton Jul 2 '15 at 16:51
  • DVD option is still greyed out says "Media Unknown (dev/sr0)" – prodigerati Jul 2 '15 at 16:55
  • You have to actually click the radio button! – Michael Hampton Jul 2 '15 at 16:58
  • It will not allow me to. it's "greyed out"... not click-able.... – prodigerati Jul 2 '15 at 17:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.