0

My php version is 5.4

This is what I get in phpinfo

pdo_sqlite
PDO Driver for SQLite 3.x   enabled
SQLite Library  3.6.20 

I really need to update this driver.

On PHP 5.3 you could do this with commands like yum install php5-sqlite, but now it seems I have to use pecl.

For the command pecl install pdo_sqlite, I get this:

/var/tmp/PDO_SQLITE/sqlite_driver.c: In function 'do_callback':
/var/tmp/PDO_SQLITE/sqlite_driver.c:311: error: 'zend_fcall_info' has no member named 'object_pp'
/var/tmp/PDO_SQLITE/sqlite_driver.c: At top level:
/var/tmp/PDO_SQLITE/sqlite_driver.c:636: warning: initialization from incompatible pointer type
/var/tmp/PDO_SQLITE/sqlite_driver.c: In function 'make_filename_safe':
/var/tmp/PDO_SQLITE/sqlite_driver.c:645: error: 'struct _php_core_globals' has no member named 'safe_mode'
/var/tmp/PDO_SQLITE/sqlite_driver.c:645: error: 'CHECKUID_CHECK_FILE_AND_DIR' undeclared (first use in this function)
/var/tmp/PDO_SQLITE/sqlite_driver.c:645: error: (Each undeclared identifier is reported only once
/var/tmp/PDO_SQLITE/sqlite_driver.c:645: error: for each function it appears in.)
/var/tmp/PDO_SQLITE/sqlite_driver.c: In function 'pdo_sqlite_handle_factory':
/var/tmp/PDO_SQLITE/sqlite_driver.c:720: error: 'struct _php_core_globals' has no member named 'safe_mode'
make: *** [sqlite_driver.lo] Error 1
ERROR: `make' failed

How could you solve this? If possible I would like not to recompile php - this could cause some problems on the production server.

My server is CentOS release 6.4

Thank you

  • Where did you install PHP from on this server? And why hasn't the server had security updates in two years? – Michael Hampton Jul 4 '15 at 15:59
  • I installed php from the repo remi. What do you mean by security updates? Should I update centos to 7 – user297670 Jul 5 '15 at 7:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.