-1

I am facing a error after changing the AllowOveride to ALL and then i get internal server Error.

<Directory /var/www/>
    Options Indexes FollowSymLinks
    AllowOverride All
    Require all granted
</Directory>

Can someone please Help me out from this Situation. I have .htaccess file in the /var/www/html/projecroot folder and having issue with Internal Navgation of project.

thanks.

  • Check your error logs. – Michael Hampton Jul 5 '15 at 17:02
  • /var/www/html/file_manager/.htaccess: FilterProvider takes three arguments, filter-name provider-name match-expression – kunal Jul 5 '15 at 17:04
  • i get this error in my error Log. – kunal Jul 5 '15 at 17:39
  • Then check the file referenced. The message explains the error. – Sven Jul 5 '15 at 18:23
0

i have solved my error and i had issue with my .htaccess file and the Mod Filter Provider syntax has changed in the Apache version2.4 and my .htaccess file had the Filter provider from apache version 2.2.

solution

  • change the Filter provider for apache 2.4 in .htaccess

AllowOverride all

enable the rewrite mode apache and then restart the apache 2 .

0

The AllowOverride All directive enable .htaccess

So that mean you got an syntax error in your .htaccess, when AllowOverride is not activated the error is not triggered as .htaccess is not read.

-1

In my case, the problem appears to be on .htaccess file, wich was trying to use GZIP, but it seams my server didin't had it.

So there was no place saying my httpd.conf was missing GZIP library (that line was commented). I just remove the coment and we were ready to go.

To people who pass through same situation, full explanation here

  • This is helpful - it is likely that the issue is with a .htaccess file. It would be even more helpful if you could add information about how you discovered the problem. – Jenny D Dec 11 '17 at 14:22
  • Usually, people who leave comments saying that an answer is helpful are not the same people who downvote you. If you are taking a constructive suggestion of how to make your post even better as a personal attack, then this is probably not going to be a pleasant place for you to post. – Jenny D Dec 11 '17 at 18:52
  • @JennyD my bad, I'll edit this post with the info you need. I'm just sick of people downvoting you know? Without leaving any explanation. But, let's fix this... – Marcelo Agimóvel Dec 11 '17 at 18:54

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.