2

I followed below steps to install FUsionPBX/Freeswitch. Got to the point where phones are registering with SIP extension created. But when I changed the default gateway of the freewsitch box and restarted it, phones are no langer registering and instead give the error

"SIP/2.0 405 Method Not Allowed"

  1. Install Freeswitch/FusionPBX using script http://fusionpbx.googlecode.com/svn/trunk/scripts/install/centos6/install_fusionpbx.sh

  2. Configure FusionPBX postgresql database.

  3. Create an extension 8810 in default domain from FusionPBX GUI.

  4. Try registering IP Phone/Softphone with 8810. It works.

  5. Change the DHCP IP to static and change default gateway of FusoinPBX box and do following: system network restart service freeswitch restart
  6. Now try registering IP Phone/Softphone with 8810. It doesn't work. It gives error: "SIP/2.0 405 Method Not Allowed" in fs_cli (sofia global siptrace on)

Find SIP detail log below:

---------------------------------
send 492 bytes to udp/[10.204.20.101]:5060 at 15:18:00.982348:
   ------------------------------------------------------------------------
   SIP/2.0 405 Method Not Allowed
   v:SIP/2.0/UDP 10.204.20.101:5060;branch=z9hG4bK80248a0c0c22e511a4b815b2652e6831;rport=5060
   From: "PhonerLite8811" <sip:[email protected]>;tag=1756292461
   t:"PhonerLite8811"<sip:[email protected]>;tag=8cU8FFr5S4yaK
   Call-ID: [email protected]
   CSeq: 14 REGISTER
   User-Agent:FreeSWITCH Rocks!
   Allow:INVITE,ACK,BYE,CANCEL,OPTIONS,MESSAGE,INFO,UPDATE,PRACK,NOTIFY,PUBLISH,SUBSCRIBE
   k:precondition,100rel,path,replaces
   l:0

Below is extension v_8810.xml conf created automatically by FusionPBX>Add Extension:

params

  param name="password" value="8810"/
  param name="reverse-auth-user" value="8810"/
  param name="reverse-auth-pass" value="8810"/
  param name="vm-password" value="8810"/
  param name="vm-enabled" value="true"/
  param name="directory-exten-visible" value="true"/
  param name="dial-string" value="{sip_invite_domain=${domain_name},leg_timeout=30,presence_id=${dialed_user}@${dialed_domain}}${sofia_contact(${dialed_user}@${dialed_domain})}"/
/params
variables
  variable name="domain_name" value="10.204.20.112"/
  variable name="domain_uuid" value="dcce9d7a-a293-4430-95a3-7cff79537a97"/
  variable name="extension_uuid" value="4b25f9dd-5b1b-4efb-b0b5-55e5f88f490c"/
  variable name="toll_allow" value=""/
  variable name="call_timeout" value="30"/
  variable name="accountcode" value="10.204.20.112"/
  variable name="user_context" value="10.204.20.112"/
  variable name="directory-visible" value="true"/
  variable name="limit_max" value="5"/
/variables

I am using following versions-

OS: Linux centos66 2.6.32-504.23.4.el6.x86_64

FusionPBX version: 3.8.4

Freeswitch version: 1.4.19+git~20150619T182323Z~73f45e3758~64bit (git 73f45e3 2015-06-19 18:23:23Z 64bit)

Someone please help! I am even happy to hire you for 1 hr if you can actually fix it.

2 Answers 2

1

I had the same problem after a clean install. I found the context in the Internal Profile was set to "public". After I changed this context to "default" the registrations worked as expected.

Hope this will help.

2
  • Hi Jim, Thanks a lot for your post. It worked for me as well. You are life saver mate. Commented Jul 9, 2015 at 23:18
  • it worked for me too ;)
    – Juned
    Commented Nov 24, 2015 at 13:04
0

It would be hard to guess since you didn't share your extension in question sip config, But 405 not allowed usually means that there is no "allow" in the URI header. what I would try to do is change the extension sip from type=friend to type=peer, but again, this is just a rough guess. share the config and I will able to assist more.

1
  • Hi I have added extension sip config in my question. Can you have a look? But the same config works for default installation. When i change default gw of freeswitch/fusionpbx box, the phone can't register. Thanks. Commented Jul 7, 2015 at 1:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .