I'm running the Postfix mail server ru000397.widhost.net. I'm getting some of these messages in postmaster@ru000397.widhost.net.

The mail service is working and, obviously, there is much free space on all drivers.

Transcript of session follows.

 Out: 220 ru000397.widhost.net ESMTP Postfix
 In:  EHLO m145.gem.godaddy.com
 Out: 250-ru000397.widhost.net
 Out: 250-PIPELINING
 Out: 250-SIZE 52428800
 Out: 250-ETRN
 Out: 250-STARTTLS
 Out: 250-AUTH CRAM-MD5 DIGEST-MD5 LOGIN PLAIN
 Out: 250-ENHANCEDSTATUSCODES
 Out: 250-8BITMIME
 Out: 250 DSN
 In:  MAIL FROM:<mailman@m145.gem.godaddy.com> BODY=8BITMIME
 Out: 452 4.3.1 Insufficient system storage
 In:  RCPT TO:<info@gilperformance.it>
 Out: 503 5.5.1 Error: need MAIL command
 In:  DATA
 Out: 503 5.5.1 Error: need RCPT command
 In:  QUIT
 Out: 221 2.0.0 Bye


For other details, see the local mail logfile

main.cf: http://pastebin.com/RCBx891e master.cf: http://pastebin.com/1HMyXzuT

Here is my df outputs:

[root@ru000397 ~]# df -h
Filesystem      Size  Used Avail Use% Mounted on
/dev/sda2        22G   20G  1.5G  94% /
tmpfs           7.8G   12K  7.8G   1% /dev/shm
/dev/sdb        2.7T  1.7T  867G  67% /usr/local/psa

[root@ru000397 ~]# df -i
Filesystem        Inodes    IUsed     IFree IUse% Mounted on
/dev/sda2        1455328   242748   1212580   17% /
tmpfs            2035051        2   2035049    1% /dev/shm
/dev/sdb       181141504 11000662 170140842    7% /usr/local/psa

Here is my message_size_limit:

[root@ru000397 ~]# postconf -n|grep message_size_limit
message_size_limit = 52428800
up vote 0 down vote accepted

Are you sure you have enough free disk space for /var? How does your df -h and df -i look like? You most likely do not actually have enough space or have run out of inodes.

  • Sure. Updated question with df outputs. – Marco Marsala Jul 7 '15 at 8:44
  • How about your master.cf? Also, do you have quotas enabled on that file system? – claviola Jul 7 '15 at 19:15
  • update question with master.cf – Marco Marsala Jul 8 '15 at 6:24
  • solved. effectively space was missing on a partition in the moment I got the error, but there was free space when I checked it. Don't know why the space is bouncing up and down, but the problem effectively was the disk full. – Marco Marsala Jul 8 '15 at 9:53

Run postconf -n to print out your postfix configuration and locate the value for message_size_limit.

Check the amount of space left in /var/spool/postfix by running:

du -sh /var/spool/postfix
  • 2
    postconf message_size_limit is easier, no need to search for the value. du gives the used disk space, not the space left. – sebix Jul 7 '15 at 19:52
  • [root@ru000397 ~]# du -sh /var/spool/postfix 12M /var/spool/postfix – Marco Marsala Jul 8 '15 at 7:14

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.