1

I'm dealing with this problem on my CentOS 6.6 server: when I send a mail with PHP/phpBB (mail() function), Postfix overwrites the return path with apache@servername.

The issue is also expained in this phpBB bug report. The only way I found to deal with the issue is to patch the application and force a -f my.desidere.return-path@example.com.

The phpBB team said is a server issue, but I don't know where to start.

I've a default CentOS 6.6 installation (Postfix) + OpenDKIM (but I suspect the latter is not relevant).

Any hints?

5
  • Post the output of postconf -n – masegaloeh Jul 6 '15 at 22:11
  • And the maillog entry when phpBB send emails – masegaloeh Jul 6 '15 at 22:11
  • Just to be clear: Does phpBB include envelope sender (-f appended to email) in the last argument ("additional_parameters") of the mail() function? Ie: -fuser@example.com – dhaupin Mar 24 '16 at 14:15
  • @dhaupin no, it doesn't use any -f option at all (see the link I provided in my question) – Dr. Gianluigi Zane Zanettini Mar 25 '16 at 11:08
  • Ah i see now in the forum post. Just wasn't sure if they patched it yet, or if your serv was still doing the same thing after you added "-f" . $config['board_email']. I stumbled on this Q because our serv was doing something similar even with -f set, but come to find out the multi-domain platform had instantiated mail class for contact form that was overriding using a static email instead of per-domain emails that were called deeper in. In PhpBB case, it's a super simple fix for a bug 5 years old. So noob they haven't patched it by now. – dhaupin Mar 25 '16 at 15:16
1

Local submission via filesocket do not suppose any authentification, so return path is constructed as active UID @ hostname. You have to setup your PHP-mailer to use hostname as SMTP host instead of localhost for complete SMTP-session with MAIL FROM: command.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.