0

Hello I am running an application install which requires thread_stack = 256k in my.cnf file. The location of the file is etc/mysql/my.cnf and I updated the value and restarted the mysql server,but the value does not get updated even after the restart.

MySQL version is 5.5.35-0ubuntu0.12.04.2

On exeecuting the below query I get the size as 196608

    SHOW GLOBAL VARIABLES LIKE '%stack%'

I referred this thread and tried the start stop way but did not work.How can I make the file to be reloaded on restart?

EDIT

   service mysql start --thread_stack=256K

This command line option also did not work with error start: invalid option: --thread_stack=256K

I just checked that after running service mysql stop I am able to connect to mysql and if I do a pgrep,I can see two pid's. Is there another mysql instance running which is causing this issue? DO I need to kill the processes?

     root@ip-10-155-22-27:/# service mysql status
     mysql stop/waiting
     root@ip-10-155-22-27:/# pgrep mysql
     12813
     13103
     root@ip-10-155-22-27:/# mysql -u root
     Welcome to the MySQL monitor.  Commands end with ; or \g.
     Your MySQL connection id is 90524
     Server version: 5.5.35-0ubuntu0.12.04.2 (Ubuntu)
     Copyright (c) 2000, 2013, Oracle and/or its affiliates. All rights reserved.

     Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.

     mysql>
  • 1
    What if you write it out, e.g. put a line 'thread_stack=262144' in my.cnf and restart? – user47093 Jul 7 '15 at 15:10
  • tried it and restarted number of times, but it still does not reflect. – KillABug Jul 7 '15 at 15:26
  • Actually because it did not work with writing I went the command route – KillABug Jul 7 '15 at 15:28
0

Well I found a solution. The issue was multiple processes(threads) running for mysql. The output of pgrep in the question led me to use kill -15 -1.

This kills all the active processes for applications. Then I had to restart mysql and apache and I had the value updated.

The comments in the linked question I added by @kashani helped a lot.

I hope this helps someone.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.