1

System: Red Hat 6.5

I have a problem with libgcc, which is apparently installed in 2 different versions on my machine.

Anyway, when I try to install literally anything, I am unable to do so, because of the error:

Error:  Multilib version problems found. This often means that the root
cause is something else and multilib version checking is just
pointing out that there is a problem. Eg.:

    1. You have an upgrade for libgcc which is missing some
       dependency that another package requires. Yum is trying to
       solve this by installing an older version of libgcc of the
       different architecture. If you exclude the bad architecture
       yum will tell you what the root cause is (which package
       requires what). You can try redoing the upgrade with
       --exclude libgcc.otherarch ... this should give you an error
       message showing the root cause of the problem.

    2. You have multiple architectures of libgcc installed, but
       yum can only see an upgrade for one of those arcitectures.
       If you don't want/need both architectures anymore then you
       can remove the one with the missing update and everything
       will work.

    3. You have duplicate versions of libgcc installed already.
       You can use "yum check" to get yum show these errors.

   ...you can also use --setopt=protected_multilib=false to remove
   this checking, however this is almost never the correct thing to
   do as something else is very likely to go wrong (often causing
   much more problems).

Protected multilib versions: libgcc-4.4.7-4.el6.i686 != libgcc-4.4.7-4.1.el6_5.x86_64
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

I am aware of the fact that this question has already been asked and answered to, for example here:

https://serverfault.com/questions/597168/solving-multilib-version-problems

However the answer to this question does not work for me. When I try to run

yum install libgcc.x86_64 libgcc.i686

I get exactly the same error (shown above).

I also tried to uninstall the libgcc package, but it has a lot of dependencies, so I cannot do it using yum. When I deleted this pacage using rpm -e --nodeps rpm -e --nodeps it made really ugly mess and broke yum in the first place.

just to be clear, I attach:

bash-4.1# yum list all libgcc
Loaded plugins: product-id, subscription-manager

Installed Packages
libgcc.x86_64               4.4.7-4.1.el6_5             _some_value
Available Packages   
libgcc.i686                 4.4.7-4.el6                 _some_another_value

Could you please help me in solving this difficulty? I ask because I have no clue what should I do next. Thanks in advance for looking into it!

  • What are the actual values of _some_value and _some_another_value? – Michael Hampton Jul 7 '15 at 15:23
  • Private repos which I can't really expose – pnadczuk Jul 7 '15 at 15:24
  • Go talk to whoever runs those repos, then. – Michael Hampton Jul 7 '15 at 15:25

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.