I just started using a new HP laptop with Windows 8.1 using the same domain account I've used for years. I can remote desktop to any server / VM on the local network, however when I disconnect the session from my laptop (close the window) the RDP client crashes with the typical "has stopped working" message. This only happens with RDP connections to Windows 8 / Server 2012. Windows XP and Server 2003/2008 doesn't cause this.

In the event log on my laptop I get the following error (Event ID 1000):

Faulting application name: mstsc.exe, version: 6.3.9600.17415, time stamp: 0x5450434f
Faulting module name: ntdll.dll, version: 6.3.9600.17736, time stamp: 0x550f4336
Exception code: 0xc0000005
Fault offset: 0x000000000003d85e
Faulting process ID: 0x2164
Faulting application start time: 0x01d0ba5205a5c537
Faulting application path: C:\Windows\System32\mstsc.exe
Faulting module path: C:\Windows\SYSTEM32\ntdll.dll
Report ID: 9f129310-2645-11e5-826b-3ca82a837a3a
Faulting package full name: 
Faulting package-relative application ID: 

Googled a lot and only found instances where the RDP connection failed when trying to connect. Some solutions involved unchecking remote printers, audio, etc which I also tried.

As a final note, RDP works so it's not a major problem, just irritating having to constantly close the "has stopped working" boxes as I RDP quite a lot.

  • Are you saying when you disconnect your session on the server (and not your desktop) crashes? Or do you mean RDP crashes? Please provide more info. Are you using RDP on the local network? Or are you using it remotely over VPN?
    – CIA
    Jul 9, 2015 at 14:59
  • On local network, when I close the session from my laptop (client side) remote desktop crashes. I updated the question. Also, I've used RDP in the past on Windows 8.1 without problems, it's only on the new HP laptop. Jul 9, 2015 at 15:04
  • Have you tried reinstalling the MSTSC.exe app?
    – CIA
    Jul 9, 2015 at 15:13
  • Sorry for the question, but how do I do this on Windows 8? Jul 9, 2015 at 15:31
  • 1
    is the issue fixed? Nov 8, 2015 at 18:36

1 Answer 1


The crash seams to be caused by a HP dll (storeng.dll) which causes an access violation:

00 ntdll!NtWaitForMultipleObjects
01 KERNELBASE!WaitForMultipleObjectsEx
02 kernel32!WerpReportFaultInternal
03 kernel32!WerpReportFault
04 KERNELBASE!UnhandledExceptionFilter
05 ntdll!RtlUserThreadStart$filt$0
06 ntdll!_C_specific_handler
07 ntdll!RtlpExecuteHandlerForException
08 ntdll!RtlDispatchException
09 ntdll!KiUserExceptionDispatch
0a ntdll!RtlpWaitOnCriticalSection
0b ntdll!RtlpEnterCriticalSectionContended
0c storeng!IsMachineInLDAPStore
0d storeng!CloseStorageDriver
0e vchannel!VirtualChannelOpenEvent
0f mstscax!CChan::IntChannelCallCallbacks
10 mstscax!CChan::ChannelOnDisconnected
11 mstscax!CMCS::OnDisconnected
12 mstscax!CTSProtocolHandlerBase::OnDisconnected
13 mstscax!CTSX224Filter::OnDisconnected
14 mstscax!CTSProtocolHandlerBase::OnDisconnected
15 mstscax!CTscSslFilter::OnDisconnected
16 mstscax!CTSProtocolHandlerBase::OnDisconnected
17 mstscax!CTSFilterTransport::OnDisconnected
18 mstscax!CTSTransportStack::OnDisconnected
19 mstscax!CTSTcpTransport::DropLink
1a mstscax!CTSTransportStack::Disconnect
1b mstscax!CTSFilterTransport::Disconnect
1c mstscax!CTSProtocolHandlerBase::Disconnect
1d mstscax!CTSProtocolHandlerBase::Disconnect
1e mstscax!CTSX224Filter::Disconnect
1f mstscax!CMCS::Disconnect
20 mstscax!CSL::Disconnect
21 mstscax!CTSProtocolHandlerBase::Disconnect
22 mstscax!CoreFSM::StartStackDisconnection
23 mstscax!CoreFSM::CCFSMProc
24 mstscax!CoreFSM::CC_Event
25 mstscax!CoreFSM::StartShutdown
26 mstscax!CTSCoreApi::ForceShutdown
27 mstscax!CRdpBaseCoreApi::AsyncForceShutdownRecvThread
28 mstscax!CTSMsg::Invoke
29 mstscax!CTSThread::RunQueueEvent
2a mstscax!CTSThread::RunAllQueueEvents
2b mstscax!CTSThread::internalMsgPump
2c mstscax!CTSThread::internalThreadMsgLoop
2d mstscax!CTSThread::ThreadMsgLoop
2e mstscax!CRCV::RCVMain
2f mstscax!CTSThread::TSStaticThreadEntry
30 mstscax!PAL_System_Win32_ThreadProcWrapper
31 kernel32!BaseThreadInitThunk
32 ntdll!RtlUserThreadStart





FAILURE_IMAGE_NAME:  storeng.dll


FAILURE_SYMBOL_NAME:  storeng.dll!IsMachineInLDAPStore


    Image path: C:\Program Files\Hewlett-Packard\SimplePass\storeng.dll
    Image name: storeng.dll
    Browse all global symbols  functions  data
    Timestamp:        Mon Oct 14 18:23:32 2013 (525C1A84)
    CheckSum:         000B720E
    ImageSize:        000AD000
    File version:
    Product version:
    File flags:       0 (Mask 3F)
    File OS:          4 Unknown Win32
    File type:        2.0 Dll
    File date:        00000000.00000000
    Translations:     0409.04b0
    CompanyName:      Hewlett-Packard
    ProductName:       HP SimplePass
    InternalName:     storeng.dll
    OriginalFilename: storeng.dll
    ProductVersion:   8.0
    FileDescription:  Storage Engine Dll
    LegalCopyright:   Copyright(C) 2001 - 2013 Softex Inc.

Try to update this DLL.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .