5

I downloaded Windows Server 2012 R2 from microsoft.com as a .vhd file and am using virtualBox to run it. After downloading it, I changed the execution policy to remoteSigned, then changed the name of the computer from the standard WIN-gibberish. I restarted the computer, but on boot, server manager came up with the error:

Server Manager cannot run because of an error in a user settings file. Click OK to restore default settings and continue, or click Cancel to exit. The configuration section 'connectionStrings' has an unexpected declaration..

I clicked OK and then received a notification that the Server Manager has stopped working, giving me the options of checking online for a solution, or closing the program. When I expanded View problem details the following was displayed:

Problem signature:
  Problem Event Name:   CLR20r3
  Problem Signature 01: servermanager.exe
  Problem Signature 02: 6.3.9600.16384
  Problem Signature 03: 52156f0b
  Problem Signature 04: System.Configuration
  Problem Signature 05: 4.0.30319.33440
  Problem Signature 06: 5200435a
  Problem Signature 07: 21c
  Problem Signature 08: 35
  Problem Signature 09: IOIBMURHYNRXKW0ZXKYRVFN0BOYYUFOW
  OS Version:   6.3.9600.2.0.0.400.80
  Locale ID:    1033
  Additional Information 1: 4bf2
  Additional Information 2: 4bf27a7a351991105fd61f6f670be584
  Additional Information 3: 6462
  Additional Information 4: 64628476a512869b703f7e3ca098fb95

Read our privacy statement online:
  http://go.microsoft.com/fwlink/?linkid=280262

If the online privacy statement is not available, please read our privacy statement offline:
  C:\Windows\system32\en-US\erofflps.txt

I researched it a bit(actually a lot) and didn't find a clear resolution to this. The only resolution was on a Microsoft website where they said to update the framework. On that site OP never responded, and the question answerer marked their answer as correct.

So far I've tried:


  • Installing all Windows Updates

  • Verifying .NET is up to date

  • Running DISM.exe /Online /Cleanup-image /Restorehealth in the console, per https://support.microsoft.com/en-us/kb/947821

  • Renaming the computer to what it was previously

  • Changing the execution policy to default

  • Running WMIDiag.exe which reported the following error: 0x8004100E - (WBEM_E_INVALID_NAMESPACE) Namespace specified cannot be found

Edit:

  • Found a folder in C:\Users\Administrator\AppData\Roaming\Microsoft\Windows\ServerManager that contained a file, ServerList.Xml, that was referencing the old name of the computer. Renaming this file does not resolve the issue.

I ended up re-downloading the .vhd file which isn't really a solution but does resolve the issue. After I create a copy of the .vhd, I'll try to duplicate the issue. Does anyone have suggestions to what I(or anyone else) that runs across this issue should try?

  • Is it against any rule to post this on SuperUser as well? – Speerian Jul 10 '15 at 21:08
  • by chance have you noticed something strange in the eventlog previous to this? Maybe even after, I am thinking maybe some service failed to load for some reason..? – lolinux Jul 10 '15 at 22:01
  • Yes, you should pick one Stack Exchange site and ask your question there. Don't cross-post it on other sites. – Peter Hahndorf Jul 11 '15 at 2:25
  • So could you reproduce this problem on a fresh VHD? – Peter Hahndorf Jul 11 '15 at 2:27
  • The system is at work, but I'll attempt to replicate it at home tomorrow night. – Speerian Jul 11 '15 at 5:47
3

There is a user setting file at C:\Users\YourUserName\AppData\Local\Microsoft_Corporation\ServerManager.exe_StrongName_m3xk0k0ucj0oj3ai2hibnhnv4xobnimj\10.0.0.0\user.config. This file will be updated when user made any setting change on UI, and sometime this file can get corrupted because of crash or turn-off.

Try manually deleting the file and restarting Server Manager.

5

I had this issue after upgrading from 2008 R2 to 2012 R2.

Installing the latest version of .NET Framework (4.7) from Microsoft's website fixed the issue.

  • 1
    Confirmed. Server manager tried to open automatically and failed at first login after Upgrade from Server 2008 R2 to Server 2012 R2. Immediately (before using Windows Update) downloaded and installed .NET 4.7 which required a reboot. dotnet.microsoft.com/download/dotnet-framework/net472 – Dave Dec 27 '19 at 20:50
1

I was having the same issue on Server 2012 R2 with Essentials role enabled.

I attempted deleting the config file as mentioned above and it did not yield the desired result.

I have seen on other sites where there is an issue with in graphics adapter. I checked the adapter driver and noted that it had been updated. I rolled backed the adapter driver and now the server manager is working as it should.

-1

Its the issue with the graphics driver.. uninstall it and restart the server.. server manager will be working fine.. its worked for me..

  • 1
    How did you determine this, since 1) there's no evidence posted by the OP showing that, and 2) this issue was resolved a year ago, and the issue had nothing to do with being a graphics driver? – David Makogon Jul 26 '16 at 13:53
  • @DavidMakogon Looks like it can be caused be a graphics issue based on Dave Crawley's answer. – Speerian Mar 2 '17 at 21:27
-1

I've had the same issue and it's been resolved for me by performing the following as suggested by Chris Vann here: MSDN Forum Thread

...it was caused by missing / renamed machine.config xml file from the .net 4 installation folder located in the following location:-

C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Config

Restored the file from backup then now Server Manager, Group Policy Manager and other mmc issues resolved"

  • Hello, Can you give us the instructions provided by the link instead of the link itself? – bgtvfr Jul 18 '17 at 10:34

Not the answer you're looking for? Browse other questions tagged or ask your own question.