2

I need to install CentOS 7 on a HP ProLiant DL360e Gen8 server.

The RAID1 has been configured in the bios: RAID Configuration

I have downloaded the driver from http://downloads.linux.hp.com/repo/spp/rhel/7/x86_64/2014.06.0_supspp_rhel7.0_x86_64/hpvsa-1.2.10-120.rhel7u0.x86_64.dd.gz

(In theory, you should be able to download this through http://h20564.www2.hp.com/hpsc/swd/public/detail?sp4ts.oid=5249572&swItemId=MTX_7db7797756df4cd9825a5567e8&swEnvOid=4176#tab3 but the file you get then is not a valid gzip file EDIT: The file is valid, it is unzipped upon download by a lot of browsers, but still named .dd.gz, which is very confusing.)

I have unzipped this .gz file and copied it to an USB key using the following commands (Done on a MAC):

  1. Insert the USB key and see that it gets mounted automatically
  2. Check the mount point using mount. For me it printed: /dev/disk2s1 on /Volumes/STORE N GO (msdos, local, nodev, nosuid, noowners)
  3. Unmount the USB key using: diskutil unmount /Volumes/STORE\ N\ GO/
  4. Run: sudo dd if=hpvsa-1.2.10-120.rhel7u0.x86_64.dd of=/dev/disk2s1
  5. Eject the USB key: diskutil eject disk2s1

I have then inserted the CentOS 7 Installation ISO and the USB key in the server and started. At the screen where you can confirm to start the installation (or test the media first), I pressed ESC to go to the "boot:" prompt and typed:

linux dd blacklist=ahci

After a few moments, it prints:

DD: Checking devices

Page 1 of 1
Driver disk device selection
DEVICE     TYPE      LABEL             UUID
1) sda1    ext4      OEMDRV            xxxxxxxx
2) sr0     iso9660   CentOS 7 x86_64   yyyyyyyy

# to select, 'r'-refresh, 'n'-next page, 'p'-previous page or 'c'-continue:

I selected 1, then I got:

Select drivers to install
1) [ ] /media/DD//rpms/x86_64/kmod-hpvsa-1.2.10-120.rhel7u0.x86_64.rpm

# to toggle selection, 'n'-next page, 'p'-previous page or 'c'-continue:

I again typed 1 to select the driver, which then changed the screen to:

Select drivers to install
1) [X] /media/DD//rpms/x86_64/kmod-hpvsa-1.2.10-120.rhel7u0.x86_64.rpm

# to toggle selection, 'n'-next page, 'p'-previous page or 'c'-continue:

I then pressed 'c' to continue which then printed

DD: Extracting files from /media/DD//rpms/x86_64/kmod-hpvsa-1.2.10-120.rhel7u0.x86_64.rpm

It then printed the first screen again and I pressed c again. After that the installer started. However, it still did not see my RAID1 drive:

Installation screen

The drive you see is the USB key.

What am I doing wrong to get the CentOS installer "see" my RAID1 disk?

1

As soon as the driver loads, you need to pull the USB key out of the server. Otherwise, the USB key's presence will impact the SCSI device enumeration.

The Driver Disk menu will also say something to the effect of "Remove the driver disk"...


I don't want to offend, but the instructions from HP do work. Please ensure you do the following:

  • Download the current driver disks for your specific OS revision. Today, that means hpvsa-1.2.14-100. If you're using EL7.0, use that download. If you're using EL7.1, use the corresponding download.
  • Create the USB key.
  • For your controller and OS, append inst.dd to your kernel boot command line.

IMPORTANT: Remove the USB-Key once the driver has been installed to prevent the OS installer from including the USB-Key as part of the OS storage.


  • Does not work. I never saw something like "Remove the driver disk". I unplugged the USB key as soon as something was being printed after "extracting driver". I tried it twice. – Wim Deblauwe Jul 13 '15 at 11:50
  • @WimDeblauwe Use a newer driver and be sure to follow HP's instructions noted above. – ewwhite Jul 13 '15 at 12:01
  • Can you elaborate on "For your controller and OS, append inst.dd to your kernel boot" ? What is kernel boot and how to I append something to it? – Wim Deblauwe Jul 13 '15 at 12:05
  • 2
    The issue was that I used the 7u0 driver with a CentOS 7.1 installation disc. I have now used a CentOS 7.0 installation disc and it works. It's annoying that you don't get an error on that. Note that the "remove driver disk" message never appeared. I did remove the USB key quickly after the driver was extracted and it worked. – Wim Deblauwe Jul 13 '15 at 14:37
  • 2
    @WimDeblauwe The downloads are not corrupt. It's actually that you're downloading using the Safari web browser on a Mac. The browser automatically uncompresses the Gzipped (.gz) download. There's nothing wrong with the content on the HP website. – ewwhite Jul 13 '15 at 14:47
-1

I had a very similair issue, but the real issue was that my server model is ProLiant DL20 Gen9 but the actually raid card is i140 model, which I never noticed.

So the wrong files I was using: hpvsa-1.2.14-100, which downloadable from a page specified for B120i and B320i.... which I guess they meant the raid model and not the server model.

Nonetheless the correct file I should have been using is: hpvsa-1.2.14-140

Note, you have to extract the gz file and change the extension from .dd to .img if you are mounting it into a virtual floppy from the virtual remote console

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.