2

Last week, I bought two QLogic Fibre Channel adapters QLE2462 to start learning about Storage Area Network. I put it to two Dell PowerEdge T110 Servers and connected them using two LC-LC duplex cables. Servers are running Ubuntu 14.04 LTS. I would like to configure first as FC target and second as FC initiator. On target I installed targetcli, I created targets, luns and ACLs, initiator sees it so everything seems to be fine. But there is one problem: transmit and receive speeds between the adapters are very random.

For example: after a period with good transfers (400MB/s transmit or 400MB/s receive or 350MB/s and 350MB/s simultaneous transmit and receive) there is a period with very slow transfers (in range from 1MB/s to 200MB/s) or LUNs are inaccessible. LUNs created on target server are RAM disks.

I have found that moving connectors at ends of cables have great impact on speed, for example when I plug a connector to port on adapter to the end (there is a "click" sound) there are slow transfers and when I gently draw it out transfers are good. This is not a solution because after some time the situation is reversed and transfers are slow again so I must "correct" connectors and it works good again.

Cables are 1 meter long. I suspect that adapters or cables have failed, but I do not have opportunity to check it in another environment. Maybe I did something wrong, my SAN knowledge in minimal... What could be the reason for this unstable behaviour?

1

Same problem here. It appears to be faulty FC card. I also tried different cables and I plugged the card into different computers and into different initiators. The result was always the same. When I tried new card, everything worked fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.