2

There's another interesting issue regarding Microsoft Outlook (Office 365 / 2013), Exchange 2013 SP1 and Active Directory. On a freshly installed Windows 7 x64 Professional computer I installed Microsoft Office 365 and tried to connect to our local Exchange 2013 Server. Suddenly the following error appears:

"Cannot start Microsoft Outlook. Cannot open the Outlook window. The set of folders cannot be opened. You must connect to Microsoft Exchange with the current profile before you can synchronize your folders with your Outlook data file (.ost)."

Regarding to the office support sites (https://support.office.com/en-za/article/I-can-t-start-Microsoft-Outlook-2010-or-2013-or-receive-the-error-Cannot-start-Microsoft-Office-Outlook-Cannot-open-the-Outlook-Window--d1f69da6-b333-4650-97bf-4d77bd7abb85), the problem should be resolved as follows:

  1. Run outlook in safe mode --> same error
  2. Create a new user profile in Outlook: Control Panel --> Mail --> Profiles: Deleted the old profile, created a new one. Account was created successfully, but Outlook won't start. Same error.
  3. Run outlook.exe /resetnavpane --> same error
  4. Repair Outlook Data files using scanpst.exe --> the application doesn't even start. It appears in task manager for a short time and then disappears again. When trying to open the .ost-File with scanpst.exe it opens. After the start of the repair process an error appears saying, that Outlook does not recognize the ost-file.

Some more attempts:

Creating another datafile and trying to switch the file in the email account. The data file cannot be switched because the "Browse"-Button is grey. Even though the newly created datafile is set as default. When set as default Outlook starts, but does not get emails in the new datafile. Other mailboxes also cannot be added.

Another interesting fact is that this problem only occurs when I'm logged in with a specific user. Other users on this computer can access their mailboxes through outlook without any problems.

//Edit 2015-07-14 16:27 I also tried to open outlook on another computer with the same user. The problem seems to be pretty much the user.

  • Your last paragraph seems to point to a problem with the mailbox and not with Outlook or the computer in question. Can you open the mailbox in question using OWA? Is the AD account linked to the mailbox in order (e.g., account enabled, password not expired, etc.)? BTW, an Exchange mailbox is not a PST, so scanpst.exe is not even worth trying. – Todd Wilcox Jul 14 '15 at 13:52
  • Yes the mailbox is accessable using OWA and also other mailboxes where the user has got permissions can be opened using OWA. I didn't see any problems with the user account itself. At least as I could say. The account is enabled and also got a new password set today (just in case). The user is currently using another computer connecting with outlook 2010 and it works fine. – Kevin Jul 14 '15 at 13:55
  • Have you tried toggling cached mode off and on for this account? – BlueCompute Jul 23 '15 at 9:19
  • Of course I did :-) – Kevin Jul 24 '15 at 10:26
0

I'm not sure if the problem could have been solved in another way but I am going to present you what finally worked for me. It seemed that the user's mailbox was damaged somehow. I still don't know exactly what the problem was. So my solution finally was to re-create the users's mailbox.

Export the users's email to a pst-file using the Exchange Management Shell:

New-MailboxExportRequest -Mailbox "username" -FilePath "\\path-to-share\filename.pst"

You can check the status using:

Get-MailboxExportRequest | Get-MailboxExportStatistics | fl

It may happen that either the ExportRequest or the ImportRequest gets stuck in the status "Queued". In my case I had some other ExportRequests in my Get-MailboxExportRequest result. You may remove the completed requests using this command per example:

Get-MailboxExportRequest -Status Completed | Remove-MailboxExportRequest

or a specific one using this:

Remove-MailboxExportRequest -Identity "OU\structure\to\useraccount\MailboxExport1"

After I removed all other requests the status of the desired request changed from "Queued" to "In Progress".

Once the export is completed we need to disable the user's mailbox first. Be aware that removing the mailbox before it was disabled would also remove the whole active directory user account. The disabling removes the connection between the user account and the mailbox.

Disable-Mailbox -Identity "username"

Now we need the MailboxGuid of the disabled mailbox. We can list the disabled mailboxes on our exchange database using:

Get-MailboxStatistics -Database “Mailbox Database Name" | where {$_.disconnectdate -ne $null} | select displayname,MailboxGUID

In my case (Microsoft Exchange Server 2013 CU4 (SP1)) the disabled mailbox wasn't in the list so I listed all other mailboxes which in my case is still OK because I don't have that many. Other users may need to use a more specific filter in their command:

Get-MailboxStatistics -Database “Mailbox Database Name" | where {$_.disconnectdate -eq $null} | select displayname,MailboxGUID

However I found the user's mailbox and copied the MalboxGuid. Then I removed it using:

Remove-Mailbox -Database “Mailbox Database Name" -StoreMailboxIdentity 92d20afd-42d8-496e-9455-34b3d6cb066e

The user's mailbox is now deleted and we are ready to create a new one. I simply logged into "ECP" and created a new mailbox for the user. After the Mailbox got created we are ready to import the exported emails into the new mailbox using:

New-MailboxImportRequest -Mailbox "username" -FilePath "\\path-to-share\filename.pst"

As before the status of this procedure can be checked using:

Get-MailboxImportRequest | Get-MailboxImportStatistics | fl

After the Import is finished I would recommend to delete the user's outlook profile and create a new one. In my case it was still buggy before I did this, and I also removed and re-assigned the permissions to other mailboxes for the user, just in case.

One last thing: After the whole procedure it happened that internal users who tried to send emails to the user's email account got an "email could not be delivered" error. I think this is because the MailboxGuid of course has changed and the server still tries to deliver the emails to the old mailbox. The users who are trying to send an email to the user's mailbox needed to get the latest changes in their offline address book done. It doesn't seem to affect all users but some, so I created a tutorial for the affected users and sent it to them if they reported the error.

I hope this will help someone who's also unlucky to have the same problem.

-1

You may have been able to solve this a lot easier. Close out of outlook on all other machines where that user may be logged in. Then open on the new computer. I have seen this issue about 4 times so far, always the user left outlook open on there old computer. Once outlook is launched on the new computer (initial setup) then you can go back to having outlook open in both places. I am trying to figure out why this behavior exists.

-2

start - controlpanal - mail - email account - e mail - dubble click on mail address -now open change e mail account box - more setting -connection tab - tik connect to microsoft exchange using HTTP - click on exchange proxy setting - now open microsoft exchane proxy setting box - uncheck connect using ssl only - and put your exchange server ip address in http:// box - ok

i suffer 4 months no one can salutation even microsoft also ....

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.