0

I am trying to figure out how to manually copy the Windows Server 2008 backup partition to a Samba share. The purpose is to consolidate several machines worth of backup data into one location for writing to a tape drive.

I have an automated task which creates the daily backup, however I can't specify the location for the backup as the Samba share, because Samba doesn't allow System users access.

Thus, my idea is create a shell script which is invoked as an automated Task Schedule and performs the copy as a non-System user.

However, I can't figure out how to access the hidden data partition of the backup. I see in the Backup Entry the partition name, but can't figure out how to access it.

[edit: I have not created this partition, nor chosen it. It is the default location which Windows Server Backup writes to.]

  • When you say 'backup partition', are you referring to a partition you created and are putting backups into? or are you referring to the recovery partition? – CIA Jul 14 '15 at 18:09
  • good point. I'll update the question -- I'm have not created this partition, it is whatever magical location Windows Backup writes to. – Daniel Jul 14 '15 at 18:13
  • Are you talking about using the Windows Backup application? Or are you talking about the Backup utility you can use from the Hard Drive properties? – CIA Jul 14 '15 at 18:19
  • this is in relation to the Windows Backup application, yes. sorry for being unclear. Not much of a Windows'er – Daniel Jul 14 '15 at 18:49
0

If you're using the Windows Backup utility, you should be allowed to select a location from the Windows Backup Wizard. You can do this by:

  1. Going to 'Start'
  2. Clicking 'Control Panel'
  3. Clicking 'System and Maintenance'
  4. Clicking 'Backup and Restore'
  5. Editing the appropriate task to pick a new location for your backups

If you're talking about the volume shadow copy (VSS) partition (the backups and versioning files), then my recommendation would be to:

  1. Add a new hard drive specifically for volume shadow copy
  2. Migrate all volume shadow copy from all drives to the spare drive

https://technet.microsoft.com/en-us/library/dd364933(WS.10).aspx

Alternatively, you should be able to store your VSS onto a SBM share without issues:

https://technet.microsoft.com/en-us/library/jj612865.aspx

If you run into problems using an SMB share, you can mount an SMB share to your system as a local disk and that should allow you to store your VSS data there.

  • So, I see in the WSB utility I have the option to specify the location, however I can't see where it is currently writing to. If I change it, then setting it back would result in the drive being formatted. – Daniel Jul 14 '15 at 20:11
  • Then that's not how your backups are kicked off. Did you set up the backups or did you adopt them? – CIA Jul 14 '15 at 23:46
  • Previous admin already had the backup configured. I can manually schedule a backup and I think I get the same options as were used for the existing daily scheduled backup. – Daniel Jul 15 '15 at 17:27
  • Chances are, it's a scheduled task. Check your scheduled tasks for backup batch/scripts. These should be editable, and if you read the batch/script, you should be able to identify the location of the backups. – CIA Jul 15 '15 at 17:29
  • Looking into Task Scheduler I see the backup task. It runs "wbadmin start backup -tempID:{.....} -quiet But i don't see any storage location listed.\ – Daniel Jul 15 '15 at 17:40
0

If you're selecting a disk as the backup location for Windows Server Backup then WSB effectively takes over that disk and doesn't allow user access to that disk. It removes it from Disk Management (AFAIK) so it won't show up there nor in Windows/File Explorer. You're going to have to select a network share (other than your Samba share) as your backup target if you want to copy the backups to your Samba share.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.