I am trying to setup backups for my linux VMs in Azure. I am doing it through the Recovery Services facility.

All my Linux VMs are discovered and successfully registered.

But when the backup jobs run they fail for all my VMs with the following error:

Backup failed with an internal error. Please retry the operation in a few minutes. If the problem persists, contact Microsoft Support.

No more details on the errors, I have tried to re-run the jobs mutliple times and same result.

I have looked into the docos and I found this:

You can get this error for 2 reasons:

1 - There is too much data to be copied. Please check if you have less than 6 disks.

2 - The original VM has been deleted and therefore backup cannot be taken. In order to keep the backup data for a deleted VM but stop the backup errors, Unprotect the VM and choose the option to keep the data. This will stop the backup schedule and also the recurring error messages.

None of the above apply, the VM has not been deleted and only one data disk per VM.

Linux VMs were created form the Gallery so I assume the VM Agent is configured correctly (they are discovered by the Recovery Service)

Any ideas or what to look for?

closed as off-topic by EEAA, Ward, mdpc, Rex, masegaloeh Jul 25 '15 at 7:13

This question appears to be off-topic. The users who voted to close gave this specific reason:

If this question can be reworded to fit the rules in the help center, please edit the question.

  • "If the problem persists, contact Microsoft Support." <---- did you do that? Your vendor should be your first point of call before coming here. – EEAA Jul 15 '15 at 1:38
  • 2
    I'm voting to close this question as off-topic because it should be addressed to the vendor. – EEAA Jul 15 '15 at 1:39
  • 1
    Technical support is paid, and is not part of my subscription, also Microsoft recommends to bring any questions here. Also where does it state that a question that deserves to be addresses to the vendor is off-topic? that way all of the questions here are off-topic – Luis Jul 15 '15 at 1:45
  • did you try to re-register just in case? – Bruno Faria Jul 15 '15 at 11:31

I had to update the Azure Linux Agent as described here:


For Ubuntu:

wget https://raw.githubusercontent.com/Azure/WALinuxAgent/WALinuxAgent-2.0.12/waagent  
chmod +x waagent
sudo cp waagent /usr/sbin
sudo /usr/sbin/waagent -install -verbose
sudo service walinuxagent restart

Check the new version with

waagent -version

Also I had to rediscover and reregister the VMs before it started working.

Not the answer you're looking for? Browse other questions tagged or ask your own question.