-2

We have two Boxes running XEN XCP. One SR is located on an FreeNAS 9 NFS share.

For some reason the NFS share turned read only which is pretty bad for one VM whose VDIs are located on the NFS SR.

I have found many hints to change the NFS mount options from soft to hard.

I just did not find a way to remount the share read-write without rebooting the host.

I tried mount -o remount,rw /path/to/my/SR to no avail. No error message, the share is still read-only.

How can I remount my SR read-write without rebooting my host(s) ?

1
  • 1
    "did not work" is clearly not enough information, you should give out an error message at least... Jul 15, 2015 at 21:48

1 Answer 1

0

For some weird reason the server deided to export the share read-only. So re-exporting it read-write solved the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.