On our Magento store when we try to we go to the product page in the admin section to upload images, we see that the images which we already have there on the front end are missing and there is no option to add images as per usual.

enter image description here

We are running the site on Nginx & HHVM.

I checked the /var/log/nginx/error.log and I see this error:

2015/07/16 11:16:25 [error] 21444#0: *14929 access forbidden by rule, client:, server: www.store.com, request: "POST /app/etc/local.xml HTTP/1.1", host: "www.store.com"

There is nothing in the HHVM error log, not really sure what to do here.

  • I was having a similar problem, but where the images were missing for a single user. Clearing all cookies fixed the problem for me.
    – DrCord
    Aug 11, 2015 at 16:22

3 Answers 3


Ok was the error log was totally throwing me off, and had nothing to do with the underlying issue. The issue was caused by Magento & HHVM not working well together.

In the end I solved it simply by adding the following to my /etc/hhvm/server.ini file.


I found the solution to this issue on GitHub. It was also reported on GitHub here.


Just in case it helps somebody else ... my images were not displaying on the admin/backend because I had Flash player disabled in my browser (Magento CE 1.9)


This can be caused by wrong permissions set to uploaded files. Open lib/Varien/File/Uploader.php and make sure following permission are set:

Around line 219:

chmod($destinationFile, 0666);

Around line 541:

if (!(@is_dir($destinationFolder) || @mkdir($destinationFolder, 0777, true))) {

Note: This issue can also be fixed by applying patch SUPEE-7405 v1.1.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .