0

I complied PSAD from source, compilation went smoothly however when I run this command:

sudo psad --sig-update

I got this:

 Can't load '/usr/lib/psad/x86_64-linux-gnu-thread-multi/auto/Date/Calc/Calc.so' for module Date::Calc: /usr/lib/psad/x86_64-linux-gnu-thread-multi/auto/Date/Calc/Calc.so: undefined symbol: DateCalc_Day_of_Week_to_Text_ at /usr/lib/perl/5.18/DynaLoader.pm line 184.
 at /usr/sbin/psad line 3218.
2
  • Have you investigated the mismatch between PSAD's Perl requirements and what's present on your Ubuntu? What version of Ubuntu are you running? Have you tried to find a PPA for PSAD instead of doing the tarballing? Have you considered rolling up your own .deb file via fpm? Jul 16 '15 at 17:10
  • @Deer Hunter perl -v --> This is perl 5, version 18, subversion 2 (v5.18.2) built for x86_64-linux-gnu-thread-multi and I have ubuntu 14.04 x64
    – Balazs
    Jul 16 '15 at 17:16
2

I just encountered the same phenomenon and fixed it. It is caused by the lack of required modules of Perl in the system. Try this;

  1. By using cpan or cpanm (Perl module manager), install Date::Calc like,

    cpanm Date::Calc
    
  2. Retry installation by ./install.pl of PSAD source tree.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.