1

I've got a DHCP role running on a Windows Server 2012 R2 machine. The scope is set in the proper IPv4 subnet. When I select "Add/Remove Bindings..." I see both the NIC with the configured static IP and the Internal virtual switch defined in Hyper-V Manager.

When I try to bind the DHCP server to either or both of these interfaces, I can check the box next to them but the "Apply" button never highlights and if I click "Ok", nothing changes. Every time I go back to that window the boxes are unchecked.

I want to provide DHCP to VMs via the Virtual Switch, and recognize that an "External" switch changes the configuration of the physical NIC so I've set up an "Internal" (not Private) switch. I also want to provide DHCP to a physical client connected via a properly configured Cisco 3750X.

The NIC that I'm trying to serve DHCP on happens to be the same one I use to remotely manage the server via RDP. I don't think this should affect anything as my laptop NIC is statically configured as well as the server NIC, both of which are outside the scope of the DHCP server but within the same subnet.

The end game is to be able to deploy Windows 10 via PXE to both VMs locally on the server using Hyper-V (and WDS) and remotely to clients on the network, but first I need DHCP working properly and this seems like a very basic problem.

4
  • 1
    So you're running DHCP on your Hyper-V host? Why don't you use a VM for DHCP?
    – joeqwerty
    Commented Jul 17, 2015 at 15:38
  • I will add to @joeqwerty, that using any more role on the hypervisor (host) than hyper-v cancel the free license you can get with MS depending on your Windows Server license ( std = 1physical for 2 vm), enterprise 1 for 4vm)
    – yagmoth555
    Commented Jul 17, 2015 at 16:06
  • This is all in a lab environment. The reason I wanted to run DHCP on the Hyper-V host was to serve to both VMs and external hosts from the same server. I realize I could do this in a VM with an "External" virtual switch but I hadn't considered that configuration. I might try that later, but I'd like to resolve this problem as well. Thanks for helping!
    – Philip E
    Commented Jul 17, 2015 at 17:03
  • If the VM is connected to the external network it can give out DHCP addresses to external machines.
    – albal
    Commented Aug 10, 2015 at 2:26

3 Answers 3

3

This is likely because WDS is installed and using port 67 on the same server.

You'll need to modify the settings of WDS to not use port 67, which can be accomplished with this command:

wdsutil /set-Server /UseDhcpPorts:No

https://support.microsoft.com/en-ca/kb/954410

0

Had the same problem on the new DHCP server on WS 2019. Turned out to be "PXE responder service" blocking port 67. As soon as I stopped it I was able to save the binding.

0

This problem still exists in 2024. Here was my way to find the solution :

On the DHCP Server run the command : netstat -anop UDP

Near the first lines you will find : UDP 0.0.0.0:67 : 123456

The end number is the process number listening on that port.

Run command : tasklist

Search the process PID with the number found by netstat (123456 in this sample)

Kill this process : Taskkill /F /IM:processName.exe

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .