1

Somewhere along the line, I went down the rabbit hole trying to avoid a SAN certificate and get away with a single certificate that would cover the RDWeb/Gateway/host of the single-server deployment of Remote Desktop Services/RDWeb/Gateway/Session Host (RDS01)

Now, I have no idea how I changed the Remote Computer parameter to remote.contoso.com, which is the same as the gateway, but cannot be resolved/proxied. **

What's weird is that I'm sure I've fixed this, but after a reboot, it seems to not be persisting.

Looking for canonical ways that this could be changed (Powershell/Registry entr(ies), configuration file(s), etc.) with the end-game being to get it back to "normal": where a simple QuickCollection for Remote Desktop sessions would take the fully-qualified hostname of the Session Host and auto-generate that as the Remote Computer in Remote Desktop shortcut/file on the RDWeb website.

** or its possibly a hairpin NAT issue; not 100% why the single server stack cannot proxy onto itself as that hostname, because I do have split DNS enabled, so you can from another host RDP to remote.contoso.com from within the same network as RDS01. Perhaps it's some loopback safety measure?

1

This appears to be persisting. ProTip Kids: make notes!

Set-RDSessionCollectionConfiguration –CollectionName <your collection> -CustomRdpProperty “use redirection server name:i:1 `n alternate full address:s:RDS01.corp.contoso.com”

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.