0

im trying to connect an application to FreeSWITCh using ESL. the code is ok (it works on other machines) but on one installation its not connecting.

im trying to connect to localhost:8021

but the esl.Connected = 0

how/where can i find information WHY the connection is not working? is the password wrong? is the service down etc? shouldnt there be any error message?

i also set the debug level to 7 but the log shows no information regarding the failed connection (or at least i couldnt find any)

any ideas?

heres the event_socket.conf

<configuration name="event_socket.conf" description="Socket Client">
 <settings>
  <param name="nat-map" value="false"/>
  <param name="listen-ip" value="0.0.0.0"/>
  <param name="listen-port" value="8021"/>
  <param name="password" value="ClueCon"/>
  <!--<param name="apply-inbound-acl" value="lan"/>-->
  <!--<param name="stop-on-bind-error" value="true"/>-->
 </settings>
</configuration>

i also tried temporarily disabling windows firewall, thought i dont think this can be an issue while connecting to localhost

i would appreciate any help

TIA!

1 Answer 1

1

meni,

You are trying to connect to localhost:8021. Do you have IPv6 enabled? You have freeSwitch IPv4 enabled, (0.0.0.0). On an IPv6 Windows 7 machine localhost is an IPv6 address (::1). Try using the IPv4 localhost address (127.0.0.1) instead of the abstract "localhost" name.

Todd

1
  • thanks a million! connecting to 127.0.0.1 did the trick! all the best!
    – meni
    Jul 27, 2015 at 9:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.