1

on my Debian machines when I enter openssl -V I see the zlib algorithm.

On Ubuntu I do not have zlib support for openssl, so the SSH also not support zlib.

Why is this?

I tried several thing to get zlib support on Ubuntu for SSH but I failed.

Can anyone helpo me?

King Regards

  • What have you tried? You should just be able to add Compression delayed to your /etc/ssh/sshd_config. – EEAA Jul 22 '15 at 18:25
  • I tried "Compression yes" but openssl -V does not show zlib in the list. – Franz Jul 23 '15 at 6:24
1

OpenSSH links dynamically to zlib. You can see this by running ldd /usr/bin/ssh and looking for the libz.so.1 reference. The fact that OpenSSL does not show zlib does not mean that OpenSSH cannot use zlib.

  • ok, thanks but when I try to connect with my client I always get this error "negotiation failed" - thegeekstuff.com/2008/07/… Does this mean that the compression via SSH does not work properly? – Franz Jul 27 '15 at 9:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.