6

My exchange server is really suffering at the moment. I do not know what has happened but when I connect via https (ECP/OWA) or via outlook (with in the network) I get 503 errors on ECP/OWA and Disconnected/Trying to connect in Outlook. I assume it is the same issue for both.

I think Exchange itself is OK, because I can use IMAP to send/receive emails. So I think it is something to do with the IIS configuration.

I get the 503 error when I log in. I get the log in page, but after logging in (correct username/pwd) then I get a blank screen with the error in the console (chrome browser). The only thing I have done today was to try a new SSL certificate, but had issues with the internal domain and external domain. I have put the SSL certificate for IIS Default site back to "Microsoft Exchange" However, it was all working when I finished this. I tested two client machines to ensure it was working.

The app pools all seem correct and are running under local admin. I have tried swapping the certificates back again, just in case, but no effect.

I have tried every combination of google search possible which has lead me to try the things I have said in the post. Unsure why it was downvoted, very unhelpful without any constructive comments.

I am now very much at a loss.

Here is some of the IIS log:

2015-07-22 23:04:36 192.168.16.3 RPC_IN_DATA /rpc/rpcproxy.dll 21ad25c4-4c9d-4367-b673-4ae3e772253e@company.org.uk:6001&CorrelationID=<empty>;&RequestId=1e098a25-e9c7-4229-b6b8-7aeb35633d87&cafeReqId=1e098a25-e9c7-4229-b6b8-7aeb35633d87; 443 - 192.168.16.35 MSRPC - 401 1 2148074254 1
2015-07-22 23:04:36 192.168.16.3 RPC_OUT_DATA /rpc/rpcproxy.dll 21ad25c4-4c9d-4367-b673-4ae3e772253e@company.org.uk:6001&CorrelationID=<empty>;&RequestId=4c1a6653-5f3b-4485-b4e2-03e59dc533be&cafeReqId=4c1a6653-5f3b-4485-b4e2-03e59dc533be; 443 - 192.168.16.35 MSRPC - 401 1 2148074254 3
2015-07-22 23:04:36 192.168.16.3 RPC_OUT_DATA /rpc/rpcproxy.dll 21ad25c4-4c9d-4367-b673-4ae3e772253e@company.org.uk:6001&CorrelationID=<empty>;&RequestId=4c22cf89-4716-4ff2-b509-1abc2e7454b8&cafeReqId=4c22cf89-4716-4ff2-b509-1abc2e7454b8; 443 RBC\bates 192.168.16.35 MSRPC - 503 0 64 44
2015-07-22 23:04:36 192.168.16.3 RPC_IN_DATA /rpc/rpcproxy.dll 21ad25c4-4c9d-4367-b673-4ae3e772253e@company.org.uk:6001&CorrelationID=<empty>;&RequestId=aae0ff8d-28d2-4c3d-8b76-7949291676e3&cafeReqId=aae0ff8d-28d2-4c3d-8b76-7949291676e3; 443 RBC\bates 192.168.16.35 MSRPC - 503 0 64 167

This seems to be related (it is the 503 error)

1
  • Can you show us some logging from the IIS server? 503 is just service unavailable which could be a lot of stuff.
    – jackhamm
    Jul 22, 2015 at 23:19

6 Answers 6

6

No thanks to the helpful down voters. The nice people at Experts Exchange helped out.

The solution was the SSL certificate seemed to have come off of the Exchange Backend website. Selected the Exchange certificate on the IIS site and it started working. for all the details please see http://www.experts-exchange.com/questions/28699498/Exchange-2013-ECP-OWA-Outlook-all-failing-503-Service-Unavailable.html

1
  • 1
    Yes! Just what I need. Experts-exchange gate locked solution
    – Blue
    Sep 18, 2020 at 15:44
1

I also had very similar issues where after a reboot of the Windows Server my Exchange instance was installed on, I was encountering 503 errors on all web sites (OWA, ECP etc). After around 30 minutes of troubleshooting, I realised the system clock was off around 20 minutes. Just adding this here to hopefully save someone the frustration in the future!

0

In my case, I fixed it in IIS. It was Exchange Back End in Bindings Site not having the right certificate selected in HTTPS.

0

https://support.microsoft.com/en-us/help/2779694/unable-to-open-owa-ecp-or-ems-after-a-self-signed-certificate-is-remov

This worked for me. I had to skip the new-exchangecertificate part because exchange shell could not create a session.

To resolve this issue, add the certificate back to the Exchange Back End web site by creating a new self-signed certificate, and then bind it to the Exchange Back End web site.

Note These steps should be taken on the Exchange Mailbox server role: Start Management Shell on the Mailbox server. Type New-ExchangeCertificate.

Note If you are prompted to overwrite the default certificate, select No.

Start IIS Manager on the Mailbox Server.

Expand Site, highlight Exchange Back End, and select Bindings from the Actions pane in the right side column.

Select Typehttps on Port 444.

Click Edit and select the Microsoft Exchange certificate.

From an administrator command prompt, run IISReset.

0

In ISS, Exchange Backend Bindings and select the right certificate for HTTPS. Restart ISS and wait a few minutes. This solved my problem, I couldn't reach ECP, OWA and EMS in Exchange 2013 after an update.

-1

In my case it was Exchange Back End in Bindings Site not having the right certificate selected for HTTPS.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.