1

I just stepped over from IIS 5 to IIS 8.5. I had trouble installing ISAPI Filters and FastCGI but I managed to get almost everything working. The only problem I'm facing now is that all of .html pages will give me a 500 error. Underneath here is the error:

FastCGI Error The FastCGI Handler was unable to process the request.

Error Details:

An error occurred processing config file. Error Number: 2 (0x80070002). Error Description: The system cannot find the file specified.

I have static content installed.

Even if I have only a head and body tag within here "Hello World" it'll give me this error. All PHP and JS files are working correctly.

I hope there are some of you guys with ideas about what I can do. I'm desperate to finish this..

Thanks a lot in advance

  • Is it possible for you to post your FastCGI mappings? – ngn Jul 23 '15 at 9:25
  • Hello, I managed to get this working by disabling the .html IsapiModule. I still feel like my handler mapping is weird. Over here a crop of my Handler Mappings: imgur.com/nfQB4WU. I feel like it's weird that I have so many IsapiModules? – JKL Jul 27 '15 at 7:11
0

I managed to fix it thanks to this website

Here is what I did:

  1. Delegate Handler Mappings In IIS manager, select the machine name from the left, click on Feature Delegation under Management in the middle section of the page. Select Handler Mappings from the list and select Read/Write from the right hand section of the page.
  2. Create new Handler Mapping In IIS manager, click on the web site name from the left hand side (probably called Default Web Site with a globe image next to it). Go into Handler Mappings. Add a Module Mapping (link on the right). The details should be the same as with the mapping for the .php extension, but it will be something like this:

    Request path: *.html Module: FastCgiModule

    Executable: C:\Program Files (x86)\PHP\php-cgi.exe

    Name: html

    In Request Restrictions box for this handler, have the following settings:

    Mapping: unticked

    Verbs: all verbs

    Access: none

  • You did not mark this as solved. Did you mean to leave it that way? – Michael Hampton Jan 20 at 1:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.