2

I have an error from a Veeam Hyper-V backup of a Virtual Machine in a Hyper-V host:

Unable to create snapshot (Microsoft CSV Shadow Copy Provider) (mode: Veeam application-aware processing). Details: Writer 'Microsoft Hyper-V VSS Writer' is failed at 'VSS_WS_FAILED_AT_POST_SNAPSHOT'. The writer experienced a transient error. If the backup process is retried, the error may not reoccur. --tr:Failed to verify writers state. --tr:Failed to create VSS snapshot. --tr:Failed to perform pre-backup tasks.

I cannot understand if this is a host error, a guest error or Veeam error. I tried to reboot the VM but I got the same error. I did not try to reboot the host, but I tried to change the host (this VM is inside a failover cluster of two hosts) and with this change the backup works again.

During the backup failure I ran this command in the host:

 vssadmin list writers

The output was:

>    Writer name: 'Microsoft Hyper-V VSS Writer'
>        Writer Id: {66841cd4-6ded-4f4b-8f17-fd23f8ddc3de}
>        Writer Instance Id: {f50fe40b-27d6-4a98-8713-e5a1dce54c97}
>        State: [1] Frozen

After the VM migrates to another host, the writer state changes back to "Stable".

What can freeze the VSS writers?

There is a 10103 event in the Host:

Failed to revert to VSS snapshot on the virtual hard disk '\\?\Volume{29e16157-002f-4cb4-af58-c95acbd54be9}\' of the virtual machine 'srvshare1'.
  • On the guest what applications are running? IE SQL or Exchange? – Zapto Aug 27 '15 at 11:35
  • No, it is only a file share. – Tobia Aug 27 '15 at 11:36
  • What is the option "Enable application-aware image processing" set to? – Zapto Aug 27 '15 at 11:41
  • The option "Enable application-aware image processing" is flagged in the Veeam job. – Tobia Aug 27 '15 at 13:13
  • Disabling the Application-Aware Image Processing in this particular VM it works... however, should I disable it and ignore the error or it is better to solve this trouble with VSS? – Tobia Aug 27 '15 at 14:53
0

Is the virtual machine a domain controller?

Have you tried below from http://www.veeam.com/kb1697

vssadmin list writers

The results will appear as:

Writer name: 'NTDS' Writer Id: {b2014c9e-8711-4c5c-a5a9-3cf384484757} Writer Instance Id: {ee24b741-eaf7-4663-8f95-b92ae8c5e164} State: [1] Stable Last error: No error

If not listed as stable reboot the DC.

────────────────────────────────────────────────────────── Verify that Automatic mounting of new volumes enabled. ────────────────────────────────────────────────────────── From a Run command (Win+R) execute the command diskpart.

From within Diskpart run the following command.

automount

If the results do not show “Automatic mounting of new volumes enabled.” Run the following command:

automount enable

────────────────────────────────────────────────────────── Verify that there are no .bak keys in the ProfileList within the Registry. ────────────────────────────────────────────────────────── From a Run command (Win+R) execute the command regedit.

Within the registry navigate to:

HKLM\Software\Microsoft\Windows NT\CurrentVersion\ProfileList

There will be a list of Keys, you must remove any ending in .bak

  • Unfurtunately I already tried this solution... but it did not work for me – Tobia Sep 1 '15 at 11:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.