0

According to my research an Intel Bloomfield CPU (more specific: a i7-920) should support Intel VT-x technology (http://ark.intel.com/products/37147/Intel-Core-i7-920-Processor-8M-Cache-2_66-GHz-4_80-GTs-Intel-QPI) but under linux /proc/cpuinfo does not include the vmx flag as expected:

$ cat /proc/cpuinfo
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 26
model name      : Intel(R) Core(TM) i7 CPU         920  @ 2.67GHz
stepping        : 5
microcode       : 0x11

  [...removed a few lines...]

flags           : fpu de tsc msr pae mce cx8 apic sep mca cmov pat clflush acpi mmx fxsr sse sse2 ss ht syscall nx lm constant_tsc rep_good nopl nonstop_tsc pni monitor est ssse3 cx16 sse4_1 sse4_2 popcnt hypervisor lahf_lm ida dtherm

  [...repeating up to processor 7 (HT)...]

or

$ cat /proc/cpuinfo | grep vmx
<returns no result>

As far as I understand it shows up here when disabled in BIOS but it does not. Output from rdmsr tells me Intel VT-x is enabled...?!

$ rdmsr 0x3a
5

What am I missing here? Thanks!

3

The hypervisor flag shows this is a virtual machine so the vmx flag won't show inside it unless you enable additional options in the hypervisor to allow nested virtualisation.

1
  • This is a Dom0 (Xen hypervisor) so my assumption that the vmx flag would show up here was wrong - Thanks for your help! – posi Jul 24 '15 at 4:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.