1

How can I install php53u-xml package (CentOS)? Is there still a repository where this package is available? I cannot find this package nowhere.

Info about one of installed packages:

[root@us03659 ~]# rpm -qi php53u-5.3.15-1.ius.el5
Name        : php53u                       Relocations: (not relocatable)
Version     : 5.3.15                            Vendor: IUS Community Project
Release     : 1.ius.el5                     Build Date: Mon 23 Jul 2012 05:35:25 PM EEST
Install Date: Mon 10 Sep 2012 06:28:26 PM EEST      Build Host: 339180-build01.rpmdev.rackspace.com
Group       : Development/Languages         Source RPM: php53u-5.3.15-1.ius.el5.src.rpm
Size        : 4411742                          License: The PHP License v3.01
Signature   : DSA/SHA1, Thu 09 Aug 2012 06:08:41 AM EEST, Key ID da221cdf9cd4953f
URL         : http://www.php.net/
Summary     : The PHP HTML-embedded scripting language. (PHP: Hypertext Preprocessor)
Description :
PHP is an HTML-embedded scripting language. PHP attempts to make it
easy for developers to write dynamically generated webpages. PHP also
offers built-in database integration for several commercial and
non-commercial database management systems, so writing a
database-enabled webpage with PHP is fairly simple. The most common
use of PHP coding is probably as a replacement for CGI scripts.

The php package contains the module which adds support for the PHP
language to Apache HTTP Server.
1

during the discussion (in russian), it was found the location of the server with the package archive:

https://dl.iuscommunity.org/pub/ius/archive/Redhat/5/
| improve this answer | |
  • You should use 'yum --enablerepo=ius-archive install php53u-xml'. The archive repo is disabled by default – ALex_hha Feb 23 '16 at 22:55
2

The reason you had trouble finding it is because PHP 5.3 reached end of life on 2014-08-14. IUS and other third party repositories removed their 5.3 packages from the primary repos. As the other answer shows, the IUS php53u packages are still available in the archive (for historical purposes), but you should not use them. There are multiple vulnerabilities in those packages. You either need to use a supported version of PHP or revert back to the stock PHP packages from CentOS, which will continue to get security backports for the remainder of that OS lifecycle.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.