3

I got kali linux installed on my pc for a while but now linux will not boot in gui mode , only in text mode ( terminal ).

I get no errors on booting it goes directly to the login screen .

Hope you can help me and yes I tried googling it.

3
  • What error messages?
    – GregL
    Jul 24 '15 at 11:53
  • Try using "startx" command after logging in.
    – ngn
    Jul 24 '15 at 13:40
  • 1
    I had the same issue on VBox 5.2.2 with Kali 4.14 and nvidia card on the hosting pc win10 pro : I disabled 3D and works now like a charm...
    – hornetbzz
    Dec 18 '17 at 18:32
4

Type:

gdm3 

into the command line. This should start the gui.

If this does not work:

login to tty1
apt-get update
apt-get upgrade -y
apt-get install -f gdm3

UPDATE:

I found some more to this workaround which may help you:

apt-get install chkconfig
chkconfig --level 2 gdm3
gdm3

Now the system should take you to the graphical mode.

Other users also managed to get to the graphical mode just by typing:

X
4
  • non of it works Jul 24 '15 at 14:51
  • Any error messages after typing gdm3?
    – Kevin
    Jul 24 '15 at 17:13
  • I edited the answer by the way. Please check if this works.
    – Kevin
    Jul 24 '15 at 18:12
  • Try ‘startx’. Worked for me in 2019 May 17 '19 at 12:34

Not the answer you're looking for? Browse other questions tagged or ask your own question.