5

On Windows Server 2008 R2, when I lock the machine, when I return, the Logon Screen screen doesn't remember my username:

Windows Server 2008 R2

I definitely still have a session, because when I log back in, it remembers the state for everything.

This is different that the way locking is handled in most other servers where the username is pre-filled, like this example in 2012:

Windows Server 2012 R2

Where can I go to change this setting?

3

Looks like a local or domain group policy. Run gpedit.msc on the machine in question and expand the following policy tree:

Computer Configuration > Policies > Windows Settings > Security Settings > Local Policies > Security Options > Interactive Logon: Do not display last user name

Set that to "Disabled" and see if that does it. You can run gpupdate /force from the command prompt to apply the policy change right away.

Also, or instead, check the same setting on any GPOs at the domain level that would apply to the server in question.

| improve this answer | |
  • + for the right place to look even though it didn't seem to be the issue in my case – KyleMit Jul 24 '15 at 17:59
  • 1
    Did you check the domain GPOs also? When I started writing I didn't realize at first that you were on a domain. – Todd Wilcox Jul 24 '15 at 19:08
  • I can't edit this field on my computer. I believe I should go to our sys admin to make this change. – BraveNewMath Feb 11 '17 at 7:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.